ParrotOS Installation Problem

Briefly describe your issue below:
When I try to boot from a bootable USB to parrotOS live version it is stuck on the loading screen, so instead of going to the live version to install from it, I tried the gtk-installer and the regular one.
Both gave me the same problem, after installing it didnt install the GUI so when I boot into parrotOS
I get a big “ParrotSee” logo and I get presented with the terminal.
I tried many things to resolve the problem,
1.Used multiple Bootable usb applications such as: Etcher, Universal USB Installer and RUFUS.
2.Tried multiple install options.

What version of Parrot are you running? (include version, edition, and architecture)
ParrotOS Security 64 bit amd64
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Configured to multiboot with other systems? (yes / no)
Yes Windows 10
If there are any similar issues or solutions, link to them below:
If there are any error messages or relevant logs, post them below:

Please Help Quick!
Thanks In Advance!

1.Try other pendrive.
2.Your computer is too weak?

i have a gtx 960m and 16 gb of ram, i7 6700hq and a 32 gb pendrive.
and i dont think the problem is with the pendrive.

What’s your bios/UEFI setup like? Are you selecting encrypted for the install without changing secure boot settings?