password request on wake up

Problem in short: Whenever I set my system to sleep (susupend OR hibernate) it doesn’t request a password to re-enter the session. I cannot find an option to change this - any suggestions?
Many THX

parrot security 3.6
debian standard

Top left of your desktop
System > Preferences > Look and Feel > Screensaver
Then at the bottom ‘Lock screen when screensaver is active’.