Persistence Not Persisting

Briefly describe your issue below:
I’m trying to upgrade Parrot in persistence but it’s telling me I have no room, despite having an empty 115gb persistence partition. The persistence.conf is in there too.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
4.7 Security amd64
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Live USB

Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

You don’t have enough free space in /var/cache/apt/archives/

the directory in question contains partial and failed install information for the most part.
sudo apt clean
should remove all the cached nonsense… thereby freeing the space.

I tried that in the beginning. Doesn’t help. It was that way from fresh install to USB, so didn’t have chance to get clogged. Also, it’s not persisting. Shutting down and returning starts from scratch.

How did you go about establishing persistence?
(a storage device with a persistence.conf file at it’s root) != (persistence)

I created the partition, then mounted it to a folder in mnt and created persistence.conf with touch.

I ran into this too and thought I was losing my mind. Check the contents of /boot and see if there are old installs still in there. Since that /boot folder is actually the mounted boot partition, it’s only about 377 MB in size. Delete all of the ones except the latest and you should boot right up.

Yep, that’s all minimal in there. Plus, it was a brand new USB burn. So, there shouldn’t be anything in there. The persistence partition shows in the file explorer as a mounted USB drive with 106gb free, but it’s not picked up by the system.

Ahh ok I thought this was a persistent usb that you’ve been using for a while and were upgrading to the new version. So it the problem that when you get to the USB boot menu and select Persistence it throws the error and boots into the non-persistent live OS, or does it totally crash? Also just curious, what was your process for making the USB?

I dd the image to the USB, then create a new partition with the label persistence. Mount the partition to mnt/whatever, touch persistence.conf. Then I boot from the USB, select my country, attach to wifi and save it, open terminal and type sudo parrot-upgrade, then it fails with "You don’t have enough free space in /var/cache/apt/archives/”. When I reboot, it asks me to select my country and attach to wifi again. Nothing persisted.

And when you select your country, this is after the parrot desktop has loaded and everything right? If that’s the case then it sounds like it is booting into the Live boot mode every time. So that any changes you make like configuring networks or running updates don’t appear when you reboot.

Is there ever a point after you boot the computer that you have a text based menu asking if you to choose options like:

RAM Mode
Forensic Mode


Yeah. I always select persistence, but it doesn’t save changes. I don’t think it’s noticing the persistence partition or file for some reason.

Cool cool. Are you able to boot into another computer (or I guess booting into the live boot would work too) and show us what you’re getting when you run sudo fdisk -l /dev/sd* ?

  • being whatever letter your system says it is
Disk /dev/sda: 115.7 GiB, 124218507264 bytes, 242614272 sectors
Disk model: Ultra Fit       
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xfdbeea1e

Device     Boot   Start       End   Sectors   Size Id Type
/dev/sda1  *         64   8274111   8274048     4G 17 Hidden HPFS/NTFS
/dev/sda2       8274112   8275583      1472   736K  1 FAT12
/dev/sda3       8289540 242613629 234324090 111.8G 83 Linux

Cool thanks. Honestly I would just recommend re-making the USB stick. I’ve run into this kind of thing more times I can count and a re-flash will usually fix it. Especially with persistent USBs. When it comes to adding the persistence, the Kali docs are probably the most detailed and have always shed some light on where I erred the first time.

Also double check your BIOS settings.
It’s usually that. It’ll be related to UEFI vs Legacy boot.

And of course etcher for flashing the stick.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.