Problem using proxychains


I just installed ParrotOS 3.11 and have massive problems using proxychains. I tried to use the default configuration with tor service running. At first, when i use

proxychains firefox

i got an error message ‘’ from LD_PRELOAD cannot be preloaded which i was able to fix using some forum advice with changing an entry in /usr/bin/proxychains

Now the file can be found and when i use

proxychains firefox

it appears to start, but nothing happens. firefox just opens normally, gives a bunch of terminal outputs like it usually does, but after that proxychains does not appear to have any effect. No messages about establishing a chain, no DNS, nothing. Its like i didnt even use the proxychains command at all and my ip and dns are just displayed as normal.

i have tried to play around int he standard proxychains.conf and change socks4 to socks5. I am also sure that tor is running.

Can anybody help?

ParrosOS 3.11

Debian Standard Install

No multiboot

You must change



export LD_PRELOAD=/usr/lib/

This can be done by directly editing /usr/bin/proxychains with your editor or choice

Hey thank you but as I mentioned i am already past this error. When i start proxychains I get no error at all, but also no effect. Had to switch to kali, its working without issues there

Hi everyone,
I have similar problem with proxychains.

When i start proxychains with : proxychains firefox I’m getting following mistake: ProxyChains-3.1 ( firefox: run_symlink.c:104: run_symlink: Assertiongetenv(“LD_PRELOAD”) == NULL’ failed.
I don’t know what I should do in this case. I’m new in this community, and on Linux, but I think it isn’t tiny problem. I’m very thankful for every help.

Parrot Release 3.11 32-bit
Kernel Linux 4.14.0-parrot13-686-pae i686