Problem wih broken pckgs


(olegov) #1

halow p-c i have a problem with borken pckg i’m try to use apt --fix-broken install and
dpkg --configure -a
apt-get install -f

not working its say :
parrot-tools is already the newest version (4.1+parrot1).
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
clang-6.0 : Depends: libllvm6.0 (>= 1:6.0~svn298832-1~) but it is not going to be installed
libclang-common-6.0-dev : Depends: libllvm6.0 (= 1:6.0.1-9.2) but it is not going to be installed
libclang1-6.0 : Depends: libllvm6.0 (>= 1:6.0~svn298832-1~) but it is not going to be installed
libpocl2 : Depends: libllvm6.0 (>= 1:6.0~svn298832-1~) but it is not going to be installed
llvm-6.0 : Depends: libllvm6.0 (>= 1:6.0~svn298832-1~) but it is not going to be installed
llvm-6.0-dev : Depends: libllvm6.0 (= 1:6.0.1-9.2) but it is not going to be installed
llvm-6.0-runtime : Depends: libllvm6.0 (>= 1:6.0~svn298832-1~) but it is not going to be installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).


(Nico Paul) #2

well I can tell you that the first issue is you having a severely outdated parrot iso if its 4.1+parrot1 but youre going to need to post this in the support category with the chart filled out that is pre formated for you there so we can have more info as well if we need it. have you tried installing the packages its saying are missing?


(olegov) #3

im try to ugrade parrot to the last one 4.4 not using apt dist-upgrade i wanna just install what i need like parrot-tools and parrot-privacy with security pcgs then install parrot-interface-full then all firmware without firmware-ti-connectivity couse this firmware brocken my vpn servvices how i can fix this problem if you can help


(Nico Paul) #4

I dont see any reason not to use the 4.4 image with the updated installer as it starts your system off better than the previous ones but you may want the parrot-tools-full package. can you elaborate on the firmware vpn issue youre trying to avoid/solve?