Problem with anonsurf and tor

Briefly describe your issue below:
I have a problem when I try to connect to the internet via anonsurf, I can not do it, anonsurf start but the connection seems absent and does not make me surf the Internet, more tor browser fails to install, I’ll explain, I when I click the first time on the icon to launch tor browser, the application download starts, but when it comes to install, bum hangs and does not move there, I tried to wait but after two days it seemed slightly too much.
I would like to know how I can do to solve this problem

What version of Parrot are you running? (include version, edition, and architecture)
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian Standard
Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Type into a terminal -> sudo anonsurf status
Check if it tells about the clock is not synced. If it’s not then change the hour and add the hours needed.
Check if the clock is synced by typing -> timedatectl status

If this does not work do -> sudo cp /etc/anonsurf/torrc /etc/tor/torrc && service tor restart

-> sudo anonsurf restart

Regarding tor browser problem -> Unable to start TOR Browser - Parrot 4.0 ->
1)Use the command in terminal to find Tor file’s shortcut:
sudo find / -name “start-tor-browser”
The path should be like that: /home/user/.local/share/torbrowser/tbb/x86_64/tor-browser_us/

2)Then copy the link and paste it in caja or open in terminal

3)use the shortcut of start-tor-browser-file (its name is: “Tor Browser”)

This all solved my problems with tor browser and with anonsurf not working.