Problem with Graphic Card Nvidia

To follow my old issue about Nvidia, today i tried clean install, and tried using hashcat benchmark, but it found no devices. So i tried downloading with apt “clinfo” because that is how i fixed that when i had installed Nvidia drivers but then had a problem with graphical tools not launching as root anymore.

Well now that i launched it, it happened again i can’t launch any graphical tool as root, which means “clinfo” is the culprit, but i need clinfo to detect my Nvidia card to run hashcat or John with it so i’m in a pinch.

Any idea ? I tried downloading official Nvidia drivers, still had to use clinfo for my card to be detected, tried bumblebee-nvidia its the same, and tried nvidia-drivers from repository. Also even after reboot i still can’t use graphical tools as root.

After i used “clinfo” to make hashcat detect my graphic card, here’s the message if i try to run a graphical tool as root (ex : BurpSuite)

I thought that maybe after using clinfo, the default driver changed in the configs and so i had to edit X11 to use my chipset instead of trying to run it with my nvidia card ? I have an Intel 4600 HD as graphical chipset.

is the driver properly compiled and loaded?

what is the output (if any) of
lsmod | grep nvidia

For now i did not install any drivers since it’s a fresh install(i only have nouveau-driver), do you want me to try installing the drivers from repository or official site, and do i install bumblebee-nvidia afterward ?

lsmod | grep nvidia doesn’t give anything right now. My Graphic card is a GTX 850M

Did you check the documentation page for Nvidia drivers, by the way?

You can check this page out: It might have a solution.

1 Like

Yes i did the last days a clean install of Parrot, installed everything like on the link you posted, i still had same problem, tried doing the same steps but downloading the official Nvidia drivers instead of the package nvidia-drivers, still did not work.

I’m not the only one having that issue.

Here’s how it looks with “nvidia-driver” and “bumblebee-nvidia” installed + “bumblebee.conf” modified as in the parrot nvidia tutorial. (Screenshot below)


And installing the officials nvidia driver gave the same thing. Hashcat and John cant detect my GPU, and even CPU.

Is there at least someone that ever managed to make his graphic card work on Hashcat/John on Parrot ? I’m starting to think the problem is not coming from me but rather a problem with packages installed on Parrot.

nvidia drivers work flawlessly both on my gtx 850m and on my gtx 1050ti and i can play all my applications and native linux games (not stupid pacman shit but games like shadow of mordor, mad max, deus ex etc) with full hardware acceleration support

i have encountered the hashcat problem too, but i think it depends on hashcat itself, and the problem has nothing to do with parrot because both the nvidia drivers and the hashcat packages are taken directly from debian

1 Like

I’ve used hashcat on a GTX1060 without any problems on Parrot OS.

1 Like

Thanks guys, i guess it’s me then, i will try to find the problem and if i do i will post it there. But can you tell me what you used (official nvidia/nividia packages/bumblebee) ?

If you go to the Synaptic Package Manager, it can give you a quick and easy way to see what is going on package wise. Check out the kernel and modules, libraries, and utilities sections. Like Palinuro said, Parrot takes the Nvidia and hashcat drivers/packages from Debian which should work no problem. There really shouldn’t be too many cases where you have to use different packages or drivers from the ones you get with Parrot.

Today on clean setup, i installed “nvidia-driver” “nvidia-cuda-mps” and “hashcat-nvidia”, yet when running “hashcat -I” i get ‘no devices found’. I also cannot run any graphical applications as root. (i’m user account) It’s as if the applications think i’m not running X11 but rather that i’m in console only…

Edit : For the graphical applications problem, i fixed it by running in console “xhost +local:all” which is strange, Parrot thinks i’m a virtual machine then, or a remote host something like that ? My card not being detected by security tools is still there though.

Hey y’all I’m dealing with a similar issue. When I run

lspci -vnn | grep VGA -A 12

I get:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK107GLM [Quadro K2000M] [10de:0ffb] (rev ff) (prog-if ff)
!!! Unknown header type 7f
Kernel modules: nvidia

I followed the Parrot Docs. Installed bumblebee-nvidia and modified the bumblebee.conf file. I’ve never had a dedicated GPU so I’m in the dark.
(Release 3.11 64-bit)
((Also this is my first post: Parrot Os is amazing thanks for all your work))

hashcat is currently broken on some linux distros. You can try --force and compare to cpu functionality. On ubuntu i am getting the same error, but when i use --force i still get full speed.

yeah tried --force on Parrot Home edition, couldn’t get it to work.

resolved driver issue. fresh installed parrot sec after breaking xserver. works perfectly now

will try again.

How did you make it work ? I tried again today, clean install, installed “nvidia-driver” and “bumblebee-nvidia” edited “bumblebee.conf” as in tutorial, rebooted, now again i can’t launch graphical tools as root anymore, and every security tools does not detect my GPU and not even my CPU, it’s getting annoying… If i --force on Hashcat, my CPU pops up on screen, but it stops immediatly.

Also when trying optirun glxinfo | grep OpenGL , from step 8 on Parrot nvidia tutorial, i get “[ 785.156850] [ERROR]No bridge found. Try installing primus or virtualgl.”, but if i try to install either of them i get

Which means it gets rid of my nvidia drivers…

Running “nvidia-smi” gives me “NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.”

Sorry miscom. Xserver works now, not hashcat. I had no luck with Nvidia drivers, ended up just breaking xserver.

Hashcat works for CPU but not GPU as long as I use --force.

The only way i made it work with GPU is, i installed “nvidia-driver” and “clinfo” packages, and i had to use at each boot in terminal “clinfo” for my GPU to be detected by Hashcat, John etc, but could not run any graphical tools as root.

As for CPU --force does not work for me

Actually, since Parrot 3.11 release, i can’t even run graphical tools as root anymore, i get the graphical error as shown above on screenshots… Could it be a problem with my graphic chipset ? I have HD 4600 Intel Graphics.

I just did clean install without installing any drivers, just apt update and upgrade, i get the errors still.

I still have same errors, and did search a lot about that, did not find any solutions, the system think i’m a remote host, because doing “xhost +” makes applications run as root work.

And i did not manage to install nvidia drivers for my GTX 850M, the card is working fine on Windows 10 and Ubuntu though.

I really can’t troubleshoot my problems