Problem with zeal


(gjado gdjado) #1

any solution guys after updating taking place i got some error’s, Executable ‘Zeal’ requires Qt 5.11.2,found Qt 5.11.1 ? when open zeal API Documentation


(Matt) #2

Zeal opens fine for me.

I also have Qt version 5.11.2 so make sure you are up to date (sudo parrot-upgrade).


(gjado gdjado) #3

so how can i get Qt version 5.11.2 i see in my system i have got Qt 5.11.1 may be it’s cause the problem that zeal it’s not gonna start


(Matt) #4

If you are up to date it should start. Can you paste the error here?.

Also looking at the package data, it claims to only require version 5.11 (apt-cache show zeal | grep Depends).

Where did you install zeal from? and have you tried purging and re-installing?.


(gjado gdjado) #5

Executable ‘zeal’ requires Qt 5.11.2, found Qt 5.11.1


(gjado gdjado) #6

using terminal command bro sudo apt-get install zeal


(gjado gdjado) #7

got it Error :- QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-root’


(Matt) #8

This is odd.

Try purging and re-installing.

Can you see the XDG environment variable yourself? echo $XDG_RUNTIME_DIR

Could also try zeal -f and try to force it.

It might be worth trying to install via flatpack instead.


(Amzker Pro Hacker) #9
 apt remove --purge zeal && apt autoremove && parrot-upgrade && apt install zeal 

Try This
If not work Give it to aptitude
aptutude install zeal