Problemas con antena wifi usb Melon N519 y alfa

Buenas Pajarracos tengo un problema: Cuando instalo Parrot OS Security mis antenas usb Melon y Alfa funcionan correctamente, me conecto a cualquier red wifi, cuando se actualiza el OS y se reinicia el PC, las antenas reconocen las redes WiFI, puedo ingresar contrase;a, pero ya no conectan a mi wifi solo hace el intento, pero no conecta a ninguna red, solo me puedo conectar por PCI Express o ethernet, ¿qué pasa? Nunca habia tenido este problema. :pensive::pensive::pensive::pensive::pensive::pensive:Ya reinicie el sistema y probe con Kali 2020 modo live y las Antenas funcionan correctamente, el problema esta en las actualizaciones, no se si se tenga que editar algo :pensive:. :pensive: Ayuda Please :pensive:!!

Hola Dante.
Prueba de hacer un traceroute google.es, con las antenas enchufadas y mira que respuesta te da en la terminal.

Las antenas usb no conecan a ninguna red, me conecto por Wifi, pero por PCI Express o Ethernet, reinicio el PC y con Kali 2020 live las antenas se conectan sin problema, el problema es cuando se actualiza el sistema operativo, ya que lo he instalado mas de dos veces y antes de actualizarlo todo funciona correctamente, se conectan sin problemas, cuando instalo las actualizaciones y reinicio ya no se conectan, solo solicitan el password una sola vez, pero no se conecta. El problema son las actualizaciones.
┌─[dantemex@parrot]─[~]
└──╼ $lscpu
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
Address sizes: 39 bits physical, 48 bits virtual
CPU(s): 2
On-line CPU(s) list: 0,1
Thread(s) per core: 1
Core(s) per socket: 2
Socket(s): 1
NUMA node(s): 1
Vendor ID: GenuineIntel
CPU family: 6
Model: 60
Model name: Intel® Celeron® CPU G1820 @ 2.70GHz
Stepping: 3
CPU MHz: 2195.334
CPU max MHz: 2700.0000
CPU min MHz: 800.0000
BogoMIPS: 5387.59
Virtualization: VT-x
L1d cache: 64 KiB
L1i cache: 64 KiB
L2 cache: 512 KiB
L3 cache: 2 MiB
NUMA node0 CPU(s): 0,1
Vulnerability Itlb multihit: KVM: Mitigation: Split huge pages
Vulnerability L1tf: Mitigation; PTE Inversion; VMX conditional cache flushes, SMT disabl
ed
Vulnerability Mds: Mitigation; Clear CPU buffers; SMT disabled
Vulnerability Meltdown: Mitigation; PTI
Vulnerability Spec store bypass: Mitigation; Speculative Store Bypass disabled via prctl and seccomp
Vulnerability Spectre v1: Mitigation; usercopy/swapgs barriers and __user pointer sanitization
Vulnerability Spectre v2: Mitigation; Full generic retpoline, IBPB conditional, IBRS_FW, STIBP
disabled, RSB filling
Vulnerability Tsx async abort: Not affected
Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat ps
e36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1
gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopol
ogy nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl
vmx est tm2 ssse3 sdbg cx16 xtpr pdcm pcid sse4_1 sse4_2 movbe popc
nt tsc_deadline_timer xsave rdrand lahf_lm abm cpuid_fault invpcid_s
ingle pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid
ept_ad fsgsbase tsc_adjust erms invpcid xsaveopt dtherm arat pln pt
s md_clear flush_l1d
┌─[dantemex@parrot]─[~]

Este es el resultado que salio en terminal. Obvio fue sin conexion a la red. Gracias por su pronta respuesta.

Prueba agregar las siguientes lineas justo debajo de las dos que te van a salir en: /etc/resolv.conf
nano /etc/resolv.conf

nameserver 1.1.1.1
nameserver 1.0.0.1

nameserver 8.8.8.8
nameserver 8.8.4.4

nameserver 8.26.56.26
nameserver 8.20.247.20

Dime como te fue. Un saludo

Lo voy a configurar y regreso. Muchas gracias.

No me funciono, no encuentro sentido a esta configuracion, cuando comento que el hardware funciona bien antes de descargar las actualizaciones de Parrot, cuando se actualiza por primera vez y se reinicia el equipo, las antenas ya no conectan, solo solicitan el password una sola vez, hacen el intento de conectar, pero no se conectan, estoy seguro que es la version beta 4.8 que no es compatible con mi hardware.

Alguna opcion para quedar en la version 4.7 sin usar la beta?

Estas con la beta, vale. La beta és todavía una versión de prueba donde los desarrolladores las sueltan para identificar posibles fallos, como el tuyo por ejemplo. Lo que te aconsejo es volver a instalar la versión estable 4.7 desde cero y la la beta en modo live usb para ir probando. Para reportar un problema te puedes dirigir aquí: https://community.parrotlinux.org/t/parrot-4-8-beta-test/11401
Un saludo

El problema es que tengo la version 4.7 en CD o USB cuando corro el comando apt-get update o apt-update automaticamente actualiza a la version 4.8, no se como correr las actualizaciones para que esto quede en la version 4.7, lo investigare.

De cualquier manera muchas gracias por tu apoyo y tu tiempo.