Problems with internet after opening firefox (possibly dns)

Internet not working after I open firefox or try to update system, despite being connected to network and ping working before opening firefox. Problem fixes itself when I reboot system, until I open firefox again.

I tried to change the nameserver in /etc/resolv.conf to
8.8.8.8 and 8.8.4.4 but it didn’t work and the file gets reset after reboot.


  • Parrot version in use : Parrot OS 4.11

  • Anonsurf running? : No

  • Logs/Terminal output

cat /etc/resolv.conf

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#          DO NOT EDIT THOS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
# 127.0.0 53 is the systemd-resolved stub resolver.
# run "resolvectl status" to see details about the actual nameservers.

nameserver 192.168.0.1

Comment: 192.168.0.1 is my wifi network gateway

sudo resolvectl status

Failed to get global data: Unit dbus-org.freedesktop.resolve1.service not found.

Before I open firefox, ping google.com works.

After I open firefox:

ping google.com

ping: google.com: Temporary failure in name resolution

sudo dnstool address 1.1.1.1
(Or 8.8.8.8)

I managed to permanently change the dns server to 1.1.1.1 in /etc/resolv.conf but this did not fix the problem.

It appears that whenever I try to use anything other than ping, the system somehow breaks, resulting in the Temporary failure in name resolution error.

So far I have tried to open firefox, update the system with sudo parrot-update, and ran a nmap - sn 192.168.0.1/24 scan on my network (which as far as I know shouldn’t even utilise dns); all of those managed to break something which results in the Temporary failure in name resolution error when pinging.

Edit: So apparently this issue doesn’t arrise when I’m connected via ethernet, only via wifi. If I’m connected to ethernet, everything works as it should. Driver issue maybe?

did u try??

or if you have anonsurf on, first turn it off, then run dnstool, then check your connection

Yes, that is how I managed to change my DNS adress (btw, thanks for that, didn’t know about dnstool). However, this didn’t appear to fix the problem. Not sure if it is DNS related.

Anonsurf is off, dnstool status shows method as static and adress as custom , and in /etc/resolv.conf the nameserver is 1.1.1.1

now try sudo parrot-upgrade

Updated and upgraded the system. Version as follows:

lsb_release -a

No LSB modules are available.
Distributor ID: Debian
Description: Parrot OS 5.0 (LTS)
Release: 5.0
Codename: bullseye
uname -r

5.14.0-9parrot1-amd64

Unfortunately, this didn’t fix the problem :frowning:

If you can perform parrot-upgrade the your internet is working fine

What is that problem?

As I have mentioned before (in the second comment of this thread), the problem only arises when I use wifi to connect to the internet. If I connect via ethernet, everything works as it should. That’s how I updated the system, via a wired connection.

If, however, I am connected to the internet via wifi, I can’t do updates or use firefox, the only thing I can do is ping. If I try to use firefox, nmap or try to update the system (so basically anything other than ping that might require an internet connection), not only does it not work, but it also make ping not work until the next reboot.

My troubleshooting so far went like this:

  1. Boot up system
  2. Log in with user password.
  3. Open terminal and use command ping google.com → works
  4. cat /etc/resolv.conf → shows me that my nameserver is 1.1.1.1
  5. Open firefox. It tries to load the parrotsec.org website, but can’t.
  6. Open a new tab in firefox and try to search something on google. After some time of the system trying to load google, it shows me the “Hmm. Having trouble finding that site” page.
  7. I close firefox.
  8. Try to use the command ping google.com again → Temporary failure in name resolution error.
  9. Reboot the system and log in again with user password.
  10. Open terminal and use command ping google.com → works
  11. Open firefox → breaks system
    And so on.

Again, this only happens if I am connected via wifi. If I am connected via ethernet, everything works fine.

umm,
u can ping but cannot update and you get Temporary failure in name resolution
no idea
If you have telegram account you can try t.me/parrotsecgroup
or anyhow you will also be responded here if anybody knows

change 192.168.0.1 to 8.8.8.8

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.