Pyhton-faraday

python-faraday
I was trying to update and upgrade Parrot Security OS 4.10 X64 Bit with Dual boot along with window 10 UEFI. Release Kernel Linux 5.5.0-1 But i am facing problem with Python faraday

  The following NEW packages will be installed:
  python-cffi-backend
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 0 B/83.8 kB of archives.
After this operation, 211 kB of additional disk space will be used.
Selecting previously unselected package python-cffi-backend.
(Reading database ... 434926 files and directories currently installed.)
Preparing to unpack .../python-cffi-backend_1.14.0-2kali2_amd64.deb ...
Unpacking python-cffi-backend (1.14.0-2kali2) ...
Setting up faraday (3.11.1-0kali2) ...
INFO  [alembic.runtime.migration] Context impl PostgresqlImpl.
INFO  [alembic.runtime.migration] Will assume transactional DDL.
INFO  [alembic.runtime.migration] Running upgrade  -> e61afb450465, Add custom f
ields
2020-06-29T09:04:25+0545 - faraday.manage - ERROR {MainThread} [manage.py:239 - 
migrate()]  Migration Error: (psycopg2.errors.UndefinedTable) relation "vulnerab
ility" does not exist

[SQL: ALTER TABLE vulnerability ADD COLUMN custom_fields JSONB]
(Background on this error at: http://sqlalche.me/e/f405)
Migration failed! (psycopg2.errors.UndefinedTable) relation "vulnerability" does
 not exist

[SQL: ALTER TABLE vulnerability ADD COLUMN custom_fields JSONB]
(Background on this error at: http://sqlalche.me/e/f405)
dpkg: error processing package faraday (--configure):
 installed faraday package post-installation script subprocess returned error ex
it status 1
dpkg: dependency problems prevent configuration of python-faraday:
 python-faraday depends on faraday; however:
  Package faraday is not configured yet.

dpkg: error processing package python-faraday (--configure):
 dependency problems - leaving unconfigured
Setting up python-cffi-backend (1.14.0-2kali2) ...
Errors were encountered while processing:
 faraday
 python-faraday
Scanning application launchers
Removing duplicate launchers from Debian
Launchers are updated
E: Sub-process /usr/bin/dpkg returned an error code (1)
1 Like

I’m having the exact same issue, wondering if uninstalling or purging it will help