qBittorrent can't launch - 32-bit Parrot

Hello Parrot community,

qBittorrent does not launch normally in Parrot Home 32-bit (neither in the 3.11 nor in the 4.0 beta release). When I open qBittorrent from the main menu nothing happens, nothing appears on the screen. However, in the Mate System Monitor qBittorrent appears, but only with ’Zombie’ status. See attached image.

In the 64-bit version of Parrot 3.11 - both the Home and Studio editions - qBittorrent launches without any problems (I checked).

I downloaded Parrot Home 3.11 32-bit version, and installed it in a VMware Workstation 14 Player virtual machine, using GTK GUI installer (later I installed using the Debian standard installer, but that made no difference).

The qBittorrent malfunction has been reported twice on the Parrot Forum, but with no solution provided, and neither poster mentioned whether they were using 32-bit or 64-bit Parrot OS (here and here).

Steps I have taken to try and make qBittorrent work on Parrot Home 32-bit version:

  1. I did an apt full-upgrade, which upgraded my 32-bit OS from Parrot 3.11 to Parrot 4.0-beta;
  2. I uninstalled qBittorrent using synaptic, then reinstalled it.
    Neither of these steps helped, qBittorrent still won’t launch.

The only thing that has helped so far is to launch qBittorrent from the terminal using the following command:
firejail --noprofile qbittorrent (thanks to Serverket’s post about firejail)
Strangely, when I launch qBittorrent from the terminal like this:

  • it still has ‘(sandboxed or root)’ written at the top of the program’s window frame and,
  • in the Mate System Monitor it is listed as a sub-process of firejail (see picture below).
  • I also get the following message in the terminal: Warning: an existing sandbox was detected. /usr/bin/qbittorrent will run without any additional sandboxing features.

qbittorrent_firejail--noprofile_launch

It seems that the problem may be linked to firejail. Does anyone know how to make qBittorrent launch normally in the 32-bit version of Parrot Home edition?

Thanks in advance,
Whisker


What version of Parrot are you running? Release 3.11 32-bit; Kernel Linux 4.14.0-parrot13-686-pae i686; MATE 1.18.0
apt full-upgrade to
Release 4.0-beta 32-bit; Kernel Linux 4.16.0-parrot5-686-pae i686; MATE 1.20.1

Same inconvenience here.

What I did: I downloaded a random torrent. opened it and was prompted with the “open with” dialogue and choose qbittorrent. Did the same thing with a magnet link. So now when I click either qbittorrent opens as standard application for these…simple.

It doesn’t like FIX the problem though it merely circumvents it and personally I am fine with that.

This is a weird behavior, the 64bit version, as you said, doesn’t have this issue. Have you tried the SID version? (just for the sake of trying all)
https://packages.debian.org/sid/qbittorrent

Every program with a default Firejail profile will be shown like this, unless you except it from being sandboxed, which you did and was not applied yet.

This only means that you executed qBittorrent from the bash, under Firejail control, otherwise it would be shown as a sub-process from the mate-panel or mate-menu (as you wanted the first time).

This means there is an instance from qBittorrent still in execution there. The overall problem may not be related to Firejail, but the way qBittorrent is being executed.

:large_blue_diamond: Checking the Firejail process tree (look for any qBittorrent PID)

firejail --tree

:large_orange_diamond: Stop all qBittorrent instances in execution including any "zombie"

:large_blue_circle: Launching qBittorrent with Debug Mode

firejail --debug --noprofile qbittorrent

:red_circle: Launching without Firejail

/usr/bin/qbittorrent

Finally, if it works, you might change the path from the mate-panel or mate-menu icon.

Thanks @Polly and @Serverket for your prompt responses to my query! Great forum - looks good and friendly people :slight_smile:

@Polly,
I tried your nifty workaround with normal torrent files and I’m pleased to say it worked.
Haven’t yet tried it with magnet links.
However, if I save an iso.torrent seed file to my computer and try and run it from there qBittorrent launches as a Zombie process once again.

@Serverket,

  1. When you suggest trying the Debian SID version, do you mean I must manually download the source packages from the SID webpage, or must I add the Debian SID repository to my list of repositories?
    (I’m new to Parrot and a bit confused about Parrot repository protocol: from some posts on the forum and on the Parrot wiki list of mirror sites it states that the repository file /etc/apt/sources.list should be empty and /etc/apt/sources.list.d/parrot.list should only have deb http://deb.parrotsec.org/parrot/ parrot stable main contrib non-free activated - I get the impression that it is considered bad practice for Parrot users to use other repositories apart from the default repositories listed in /etc/apt/sources.list.d/parrot.list or official mirrors. Do I understand correctly?)

  2. Launching qBittorrent with Debug Mode: firejail --debug --noprofile qbittorrent and
    launching without Firejail: /usr/bin/qbittorrent worked.

  3. Please give me some tips on how to "change the path from the mate-panel or mate-menu icon."
    I’ve looked at firejail’s qBittorrent profile and it is the same as the one on 64-bit Parrot, and I’ve tried commands such as whereis -l qbittorrent, type qbittorrent, command -v qbittorrent, which qbittorrent in an attempt to find out what the computer is doing once I click on the qBittorrent button in the main menu, but to no avail.

  4. Also want to mention that when I launch qBittorrent I get the same long Gtk-WARNING readout that the original poster listed in his first post on the thread: Can’t use qbittorrent or transmission. But that’s not the problem because it also appears when qBittorrent launches successfully in the 64-bit version (using command qbittorrent).

  5. Do you think Firetools would be of any use to me in this situation?

Thanks and regards,
Whisker

I meant to suggest you to download the package from the Debian SID site:

And as you said, it is a bad practice to use other repositories, I do not recommend that in this case so you got that right.

When it comes to mate-menu, if you right-click over a launcher you’ll see a drop-down menu where there is the option to edit its properties, between them [Properties] there is the field for changing its execution command, where you can place any execution call that works for you.

Firetools is just a graphical interface for Firejail, I don’t think it would make a big difference apart from let you perform some tasks in a faster way but I suggest to give it a chance.