Quallcom Atheros QCA9377 cannot see some networks

Not so far I noticed, that in Parrot 4.7 on my laptop Acer Aspire A3 A315-53G-57XY my wireless adapter Atheros QCA9337 cannot see differrent wireless networks (not all). For example - in coffee shop I do not see wireless network of this coffee shop (but on my phone it is still available) and only see other networks. Same situation at home - I’ve dual-band TP-Link router with 2 networks (one operates on 2.4 GHz, other - on 5GHz frequency). I can see only one, which work on 5GHz frequency. After fresh install and upgrade.

Does anybody have similar issues?

Parrot security 4.7, kernel 5.3.0-3parrot3-amd64
Install - debian standard

Without multiboot

Maybe. this information can be useful:
[ 24.230534] ath10k_pci 0000:03:00.0: kconfig debug 0 debugfs 0 tracing 0 dfs 0 testmode 0
[ 24.232320] ath10k_pci 0000:03:00.0: firmware ver WLAN.TF.2.1-00021-QCARMSWP-1 api 6 features wowlan,ignore-otp crc32 42e41877
[ 24.341059] ath10k_pci 0000:03:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/board-2.bin
[ 24.341437] ath10k_pci 0000:03:00.0: board_file api 2 bmi_id N/A crc32 8aedfa4a
[ 24.415892] ath10k_pci 0000:03:00.0: unsupported HTC service id: 1536
[ 24.434558] ath10k_pci 0000:03:00.0: htt-ver 3.56 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[ 30.796131] ath10k_pci 0000:03:00.0: unsupported HTC service id: 1536
[ 31.163807] ath10k_pci 0000:03:00.0: unsupported HTC service id: 1536
[ 31.803575] ath10k_pci 0000:03:00.0: unsupported HTC service id: 1536
[ 90.332885] ath10k_pci 0000:03:00.0: unsupported HTC service id: 1536
[ 132.511656] ath10k_pci 0000:03:00.0: unsupported HTC service id: 1536

Check what all is supported by the device, a cursory google search suggests it could be an unsupported channel based the “unsupported HTC service id: 1536” error. I have the same device and it works well (relately):smile: with no problems even though I broke one of the antennas :frowning:

Check what channel the access point is using and make sure its available or maybe just try changing it anyway(on the AP). I’m assuming the 5GHZ you can see isn’t yours…

1 Like

Thank you for your reply. It’s quite strange, but after i reinstall firmware-atheros package and then reboot my computer - problem was solved. Now on several networks sometimes when connection is active - I can not use internet after 5-10 minutes after connection was established. But on most networks I have no any issues. I will try to check powersave mode and disable it.

That’s good. Maybe just a software/firmware bug, not much one can do about that but better than an issue with the physical card itself.
As a side note now that I think about it I believe I encountered something similiar a few weeks back which around around the time I first this distro on my current machine where the NIC would driver/firmware would crash and the device would have to receive a reset or power-cycle to come back up again. At the time I thought it had to do with some damage I accidentally caused but now I think it was something else.

But anyway good to see we can put this in the solved pile without too much trouble.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.