Recurring Locale Issue

Operating System: Parrot GNU/Linux 4.9
KDE Plasma Version: 5.17.5
KDE Frameworks Version: 5.62.0
Qt Version: 5.12.5
Kernel Version: 5.5.0-1parrot1-amd64
OS Type: 64-bit
Processors: 4 × Intel® Core™ i3-5005U CPU @ 2.00GHz
Memory: 7,8 GiB of RAM

Below is the issue i repeatedly have, 4 or 5 times in a couple of days. I there a permanent fix for this i have missed?

apt-listchanges: Can’t set locale; make sure $LC_* and $LANG are correct!
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = “en_GB:en”,
LC_ALL = (unset),
LC_TIME = “es_ES.UTF-8”,
LC_MONETARY = “es_ES.UTF-8”,
LC_COLLATE = “es_ES.UTF-8”,
LC_MEASUREMENT = “es_ES.UTF-8”,
LC_NUMERIC = “es_ES.UTF-8”,
LANG = “en_GB.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to a fallback locale (“en_GB.UTF-8”).
locale: Cannot set LC_ALL to default locale: No such file or directory.
So I enter :
export LC_ALL=“en_GB.UTF-8” then, sudo dpkg-reconfigure locales.
And all is well untill next time ???
Can anybody please assist

It should be fixed. We are deploying it on the repository.

Well many thanks and Big Up to all
bing

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.