Repository issue?? I think???

I am getting this error message in my package manager. I have no idea what I’ve done to get this. Any ideas how can I fix this?

E: Malformed line 1 in source list /etc/apt/sources.list.d/spotify.list (type)
E: The list of sources could not be read.
Go to the repository dialog to correct the problem.
E: _cache->open() failed, please report.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Make sure your /etc/apt/sources.list.d/parrot.lst file is correct:

The only file in my directory is parrot.list. Not sure why a spotify.list is in your directory. Correct any problems then run:
apt update

Then try synaptic or whatever package manager you are referring to (apt install command etc).

I got it fixed. I’m really not sure what the problem was. The source in lines 1 and 3 were kinda strange. Line one read Clear. Line 2 was blank and line 3 read exit. That’s all it said. I just took the lines out rebooted and Taa Daa problem solved. How those two words got there is beyond me. Anyway all good now.

it looks like you tried to install spotify from their unofficial repository instead of using snap, so their software has modified the system in an invalid way

please remove it and install it via snap instead

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.