Rolling release to include Thunderbird 168.12 ?

Just installed rolling home version and trying to change the profile for Thunderbird from another “rolling” edition. Parrot has 168.11 and the others “Sparky 6” are on version 168.12 now. My profile ( .thunderbird ) wont work in the 168.11 version and the 168.12 .deb I downloaded gets stuck in dependencies with lightning. Any ideas when the Parrot will do a roll and get thunderbird up to others rolling standard ? Even LMDE4 is up to the xxx.12 version so moving my profile over to it was zero issues.