Root cannot open display

Briefly describe your issue below:

Cannot open display, trying to run application using root terminal. From local machine.
Also root user disabled im using sudo su - command from terminal.
I tried to reinstall os tried parrot security, parrot home both same problem.
I never had this problem before
I was able to run application as root using uxterm and xterm, but not terminal.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
4.7 security mate

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)

List your hardware specs to include make, model and firmware (when applicable):
Intel i5
8gb ram
Nividia 930mx

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:
Application : cannot open display
Wireshark : cannot open display no X display


Hey Ham,there is a wealth of answers for this same problem on ubuntu , debian , archlinux , unix etc. when you search duckduckgo… I should imagine it will be the same for google. I hope this helps

Nope, i tried to search for it most topics while trying to connect using ssh.
Nothing helped.

Don’t login as root

Have you checked your Nvidia930mx kernel compatibility? if you enter with a non root user still have the same problem? i use mate desktop with no problems, you can try it by installing a mate desktop environment or switching on it

Non root have same problem yes, how ever i was apply to run application from root terminal using startx

How can i do it without startx?

I dont, its terminal using sudo su -

Okay so i misunderstood. What is your graphic card name?

Intel® HD Graphics 620
Nividia 930mx

I run, apt-get install libatk-adaptor libgail-common
Solved the issue however when application run i get
"Qstandardpaths: XDG_RUNTIME_DIR not set, defaulting to ’ /tmp/runetime-root ’

Hey sorry for my lately reply. I am thinking you are having driver issue. Sadly i don’t have any hardware to check and debug and help you. Have you tried boot with “No nodeau” or something like that from grub?

No, but i wonder why im having this problem in 4.7, i used parrot os 4.2 before on the same laptop and it used to run smoothly. Why i have this problems in 4.7…

4.7 is having kernel 5.2 which could be the problem.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.