Root password issue

Yesterday I downloaded parrot os kde version now I’m having this problem it is asking me for a root password eveytime I want to use for example sypnatic package manage, the firewall, when I download something it always asks me to insert a root password i don’t what it is. I tried with my password and it does not work
Please all help is grealty appreciated

1 Like

Some utilities require the root passcode because they affect the entire system, it’s a security feature.

Synaptic, for example installs applications to /usr/bin which is then a system application for all users.

Firewall (e.g. ufw, gufw), for example modifies IPTables which affects the entire system for all users.

It may be that you need to input your user’s passcode instead of the root’s passcode because sudo is being used for privilege escalation. If you do no want to type the passcode for root activities you can login as the root user or add your user to the root group, though this is advised against.


Hi @Batmanxx

Apparently there is a bug in the PolicyKit for all Parrot 4.11 releases. Instead of asking for the user’s sudoer password, various programs needing elevated privileges are asking for the root password instead. For now, create a password for root and use that until a patch or Parrot 4.11a (?) is released.

$sudo su

enter sudo password


enter a password for root
reenter a password for root

1 Like

You can also solve this problem by creating file:
Its content should be:

AdminIdentities = unix-group: sudo

You can do this in the terminal, like this:
sudo su
enter the user password
nano /etc/polkit-1/localauthority.conf.d/51-debian-sudo.conf

Enter the text I provided as the content of this file:

AdminIdentities = unix-group: sudo

Save the changes, exit the terminal, and restart the computer.
System will no longer ask you for the root password, but for your user password.


Though i’ve created password for the root user, i tried this method and after rebooting the computer some settings still need root password. Those settings are like in the Control Panel:

  • Login Window
  • Time and Date Manager

At least these are the ones i tried. Should i make something else to let me modify those settings with my sudo password?

Thanks any help!

I did not create a root password, so for Login Windows I was not asked for root, but my user password.
Try to remove root password and lock root account again:
sudo su
passwd -d root
passwd -l root

Unfortunately it didn’t work. The password of root is still asked when i want to open Login Window or Time and Date Manger settings. I have to reinstall my PC anyway ,so this time i won’t enable root password, and i’m going to try out the polkit method once again without enabling root user. I’m gonna report back with the results.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.