Samba problem. code=exited, status=255


(D) #22

Many thanks. :pray: It worked perfect, after a reboot…

EDIT: I also had to change the permissions of /var/lib/samba/msg.sock, THEN it worked perfectly. (Just remembered i did that)

so my actual fix was : net groupmap add sid=S-1-5-32-546 unixgroup=nobody type=builtin && chmod 755 /var/lib/samba/private/msg.sock
(the permissions were 700 for some reason)

then this output:

service smbd status
● smbd.service - Samba SMB Daemon
Loaded: loaded (/lib/systemd/system/smbd.service; enabled; vendor preset: enabled)
Active: active (running) since Thu 2018-12-06 14:44:00 EST; 52s ago
Docs: man:smbd(8)
man:samba(7)
man:smb.conf(5)
Main PID: 1322 (smbd)
Status: “smbd: ready to serve connections…”
Tasks: 4 (limit: 4915)
Memory: 13.7M
CGroup: /system.slice/smbd.service
├─1322 /usr/sbin/smbd --foreground --no-process-group
├─1324 /usr/sbin/smbd --foreground --no-process-group
├─1325 /usr/sbin/smbd --foreground --no-process-group
└─1326 /usr/sbin/smbd --foreground --no-process-group

Dec 06 14:44:00 parrot systemd[1]: Starting Samba SMB Daemon…
Dec 06 14:44:00 parrot systemd[1]: Started Samba SMB Daemon.


(D) #23

After i updated ParrotSec and restarted, samba was broke. Purged it and attempted to re-install it, and now its not there. I cant re-install samba.

[✗]─[d@parrot]─[~]
└──╼ $sudo apt-get install samba
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package samba is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
samba-libs

E: Package ‘samba’ has no installation candidate

─[✗]─[d@parrot]─[~]
└──╼ $sudo apt-get install -t sa
safecopy sakis3g samba-common-bin samdump2 sane-utils
saidar samba-common samba-libs sandi

all of them are already installed

i run this:

┌─[d@parrot]─[~]
└──╼ $service smbd start
Failed to start smbd.service: Unit smbd.service not found.

mmmmhmmmm

i NEED this to work, and stay working.
Where do i start?
Thank you


(Nico Paul) #24

verify the correct parrot sources.list has the appropriate entries as written on the FAQ page then try this:

sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade

sudo apt-get install samba

this may be one of the rare instances apt-get may be the correct command to use


(D) #25

My apologies. It was a program that i attempted to install and it required a dependancy, which required me to change a file manually, which broke alot more than Samba. I backed up, reloaded. Its fine now.
Thank you.


(Nico Paul) closed #26