Screen Brightness not working

– Please Write here your help request, –
Hi, I have just installed parrot home in my new laptop (legion 5 15ach6) which has amd ryzen 7 5800h cpu and nvidia 3050ti gpu.
there are two ssd one has windows installed and another has linux and each ssd has separate /boot/efi fat32 partition (i.e one efi partition of linux and another of windows)

The problem is screen brightness control does not work, brightness always stays to 0, when I increase the brightness using slider or keyboard shortcut, the brightness bar increases but the brightness stays the same.

and another problem is how do I switch between the amd integrated gpu and nvidia dedicated gpu…?

the windows had lenovo vantage software which had hybrid mode for switching between amd display or nvidia gpu display but nothing works here in parrot.

besides when updating software it says missing formware as follow

W: Possible missing firmware /lib/firmware/amdgpu/*** for module amdgpu

I tried all the solution I found in the internet, like installing the nvidia drivers as follow

apt install nvidia-driver

and downloading the missing amdgpu firmware from github page and moving them to /lib/firmware/amdgpu
but the problem is not solved.
it still says missing firmware
and the brightness still does not work
and I still can’t switch between amd and nvidia gpu.

here are the output of certain commands
ls /sys/class/backlight

amdgpu_bl0

bumblebeed.service - Bumblebee C Daemon
     Loaded: loaded (/lib/systemd/system/bumblebeed.service; enabled; vendor preset: enabled)
     Active: active (running) since Thu 2022-02-24 18:46:25 +0545; 31min ago
   Main PID: 1409 (bumblebeed)
      Tasks: 1 (limit: 16489)
     Memory: 1.6M
        CPU: 6ms
     CGroup: /system.slice/bumblebeed.service
             └─1409 /usr/sbin/bumblebeed

Feb 24 18:46:25 doruk-legion5 systemd[1]: Started Bumblebee C Daemon.
Feb 24 18:46:26 doruk-legion5 bumblebeed[1409]: [    8.210816] [WARN]No switching method available. The dedicated card will always be on.
Feb 24 18:46:26 doruk-legion5 bumblebeed[1409]: [    8.211121] [INFO]/usr/sbin/bumblebeed 3.2.1 started


  • Parrot version in use (if you are not aware of it, open terminal and type cat /etc/os-release | grep VERSION):
    parrot home version 5.0

  • Kernel version (if you are not aware of it, open terminal and type uname -r):
    5.15.0-15parrot1-amd64

  • Logs/Terminal output (use pastebin or similar services):

  • Screenshots:

Hello. Have you tried reading the documentation yet? In any case you should already have the integrated gpu drivers. Also, you may need some utilities, like radeontool and radeontop, do a research for them.

  • In any case you should already have the integrated gpu drivers *
    can you please elaborate a bit regarding this…?
    How can I install the integrated gpu drivers?, I’ve installed parrot many times in my intel cpu based laptop and never had problem like this. All the required igpu drivers were pre installed and everything worked fine.
    I googled a lot and tried installing many packages but nothing helped,

besides there is radeon software available here
https://www.amd.com/en/support/kb/release-notes/rn-amdgpu-unified-linux-20-20
but is only for ubuntu, will the same package work for parrot…?

after downloading the nvidia drivers from official website, I tried installing it as follow:

./NVIDIA-Linux-x86_64-510.54.run
but it says couldn’t install, you are using xserver please disable it and install again.

but won’t my system crash if I uninstalled the xserver…?
anyway, apt remove says virtual package like xserver can’t be removed.

For intel CPUs the drivers are already active (mesa drivers).

Honestly I’ve never tried, but usually ubuntu packages can work on debian (depends on what they go for).

Although we have both installation procedures for nvidia drivers, my advice is to follow the documentation starting from here: Nvidia drivers - Parrot Documentation

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.