Screen Tearing and amdgpu problems

I have pretty bad screen tearing. It is most visible when scrolling in my browser and watching videos.

After hours of Googling for possible solutions, none seem to be working. Most were directing people to update amdgpu firmware and to add ‘contrib’ and ‘non-free’ tags to standard repositories and to update.

I ran:
apt install xserver-xorg-video-ati
apt install xserver-xorg-video-amdgpu
apt install firmware-amd-graphics
And the updates with non-free.

Everything says it’s installed already at the newest version, but amdgpu doesn’t seem to actually be running.

If I run 'lspci -k | grep -EA2 ‘VGA|3D’ I get the following output:
28:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] (rev c4)
Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
Kernel modules: amdgpu

As you can see it recognizes amdgpu but there is no “Kernel driver in use” indicating the driver is active.

Not really sure where to go from here as my searching has brought me to a dead end.

Version: Parrot Home MATE 4.9

Install method: Parrot GTK installer

Dual-boot with Windows 10

UPDATE: I solved the issue. When running update-initramfs, I discovered that for some reason, not all of the amdgpu firmware files were downloaded when installing the firmware packages. For future readers, this seemed to do the trick. You might also note one of the warnings from a user about newer cards like the Navi cards.

I cloned git:// and copied the missing files to /lib/firmware/amdgpu.

I then ran ‘sudo update-initramfs -u -k all’ then restarted and the amdgpu is now loaded and reading as in use. Screen tearing is solved.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.