Secure boot forbids loading modules ( Parrot OS )

–Secure boot forbids loading module from (hd0,gptx)/boot/grub/x86_64-efi/normal.efi
I want to employ secure boot to my Parrot Security OS for that I created an openSSL self signing key (x509), and signed /boot/efi/EFI/Parrot/grubx64.efi and /boot/vmlinuz with that key. Then I appended that key to my UEFI BIOS → DB keys.
After that I enabled and tried to boot parrot OS → which shows not be able to load normal module and went to grub rescue mode. In rescue prompt to too I tried insmod normal but it failed. I checked that and normal.mod file exists in that place.

I done the same process for my USB booting from Ventoy USB, where my custom signed grub.efi loads and works correctly without any problems. Hence, I suspect that it should be related to Parrot’s configuration. ( I’m also dual booting it with Windows 11 22H1 ).

Please help me find a solution. Thanks in advance!!!

  • Parrot version in use : 5.0 (Electro Ara)

  • Kernel version :5.16.0-12parrot1-amd64

  • Methods I tried,
    → signing all possible files from /boot/grub/x86_64-efi/ by sbsign.
    → ran grub-install --uefi-secure-boot.

  • Method that I want to try ( but not sure, whether it is legal or correct ),
    → copying all amd64 and boot files from Ventoy USB’s boot partition.