Seriously what is going on ?

Seriously, what is going on with Parrot Sec, i have attempted to install these dozens of times and all i get is errors and more errors. I used the installation manual to make the necessary configurations and still gives me problems, even attempted the home version and nothing. I search around for answers and most come up short, all i want is a clean set up where i can work effectively without many headaches. Kali Linux also gave me issues, any help or guidance would be greatly appreciated, thank you.

Hi. Isn’t that you were wrong to select the disc where you want to install Parrot? Never seen this error if not because the selection is incorrect at the time of installation.

1 Like

What i don’t understand what should i do, i am following the manual from Parrot OS inputting the right settings and so on.

Are you NEW to Linux?,
you mentioned Kali, to install, set up, and run Kali you need to be fully experienced in how Linux works and the use of the terminal to find and install any drivers you require, [ you will not get any help from the Kali forums if you ask a basic question]
now Parrot,
This distribution is no harder to set up than any other desktop Linux edition, P5 is new and may still have a few gremlins, but is basically solid.
If you wish to set up a solely Parrot installation and not a multi boot, then the routeen is the same as other distributions. How Do I Install Linux (A General Guide) • Linux Tips


Parrot Security 4.11.3 and also P5.0 doesn’t run the process install, … simply, just don’t go on, on a Toshiba Satelite A215s, AMD Turion64, 4GB RAM, ATI graphic! Both versions can only be tested with no problem, but can’t be installed. This laptop is running smoothly with Win7, Linux AVL Mxe21, Linux Kali, … but Linux Linux Parrot (both versions) … installation process, … simply does not proceed after ending all settings to run and with any error message. … but easily installed on a Sony laptop, with Intel Processor and 2GB RAM and also, multi boot system. I never experienced before, this issue with any other Linux releases.

1 Like

The tosh A215s only came as standard with a 160gb hard-drive [unless it’s been upgraded,]
If you are running all 4 of the distributions you list, my immediate thought is do you have enough space for another distribution on the same drive

Thank you for your fast reply, but as I said yet, also one month ago or so, … process install doesn’t run, with no error message with PS4.11.3 too! … is because I have space enough, … (45 GB assigned) … because I have a 1TB SSD Crucial model: CT1000MX500SSD1 size: 931.51 GiB speed: 3.0 Gb/s. P5 still offering two options to start installation process. The first one, it’s trying to start, but finally is unable to start. The “Calamares” option seems to work perfectly, until ending settings process, but after “Install now” … doesn’t do anything more, just close, and … nothing! I never seen this before with any other Linux release. Ah, I have also Linux Kodachi installed aside on this HD, but before install this one, I tried to install P5, with same “succes”, … no way to install! :frowning:

No i have been using Linux for some time now.

Take off general hat and put on hardware hat,
This may or may not be applicable to you, there is/was a known problem in the firmware of some production runs of the Crucial MX500 range, this only effects products with the firmware M3CR032,
[see documentation that came with your drive or check the label on the drive the firmware number should be on it]
If you have a drive with this firmware, you can update it from Crucial support using your W7 installation
No guarantees but this may fix your problem

Thanks Brian, I will check later, but I don’t think so, because if I’m not wrong, … I have the last firmware installed yet! And why 4 other linux os’s were installed with no
problem? I believe the problem is still being same since beginning, as like … just the single real developer has mentioned in January… regarding grub installing issues … maybe wasn’t fixed yet, neither on 4.11.3. I’m not a developer, but I don’t want to assign a special “grub-efi” partition, just for this “bird”! I have yet a 500MB partition assigned … same situation on the Sony laptop, were was easilly installed. Anyway, I will check the firmware.

I am not a programmer either, just a humble hardware man, but I can confirm that it is not unusual for retrograde updates to creep into the Kernel, the boys and girls that maintain the various parts on the whole do a good job, but nothing is perfect, the obvious answer to me would be wind back to an earlier kernel that is known to work, then try a new one when released

Hi Brian, again!
I don’t know, but when I firstly mentioned this issue, I was realy assaulted by a lot of “clever guys” saying I was testing a beta version, … but it was 4.11.3, … which someone of developers advertised about the grub issues, … I guess wasn’t fixed yet … and supposedly 4.11.3 is for a while, the “masterpiece” … of :bird:. I have 4 Linuxes runing, with more recent kernels working.
For sure, as I supposed, my frmware is M3CR033, … the last as I know.
The guy who told you about that, is family of Nigel Farage or Boris Johnson? :rofl::rofl::rofl:

Hi, as I said I am a hardware man, so I look at problems from a different direction to a programmer,
I start with what is the hardware problem, is the correct driver installed, is there a better driver, could it be a problem with the Hardware, then check the manuals for known faults and possible fixes [if It’s something I have not come across before]
It may wind a few people up who expect a 2line terminal code response, But it is the way I have always worked through a computer problem, and it usually yields either the right result or more information for someone else to run with, Linux is fun and the only real way to learn about it is to have problems or better still brake it and have to fix it

Thanks! … is clear to me: the installer is stopping with no error message, and I can continue testig Os. with no problem. Why… I don’t know. I believe is not a harware issue, then must be an installer bug.
And now, what?
An Os. which is running only on theirs programmers computers, is an useless system!
Best regards!

1 Like

Are you on multi boot?

Are you by any chance installing inside virtualbox? If Yes, are you using shared virtual hard disk?

Hi everybody,
I’m also not able to install Parrot in Virtualbox.
I installed several times this OS and when I start the virtualcomputer, I get the choice “try/install, and so on”, as if I started the live version.

Did you remove the iso from the virtual machine?

Thank you danterolle for your answer.

When I remove the .iso the Virtualbox shows me a screen with “FATAL: No bootable medium found! System halted.”

I solved the problem.
I removed the iso from the virtual machine and I removed the disk from the boot list. There stays only the hdd for the boot.