SOLVED CUPS Server Error

Briefly describe your issue below:

Running Parrot Home and having problems setting up a printer. I get a cups server error.

What version of Parrot are you running? (include version, edition, and architecture)
Parrot, Home, 4.2.2
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian Standard
Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:
If there are any error messages or relevant logs, post them below:

You will have to show us more info. What exactly is the error? at what stage of set up do you get it? ect…


After looking at it myself, it looks like cups probably isnt installed.
sudo apt-get install cups
Then to start cups
service cups start

Then you can either go to
localhost:631 in your browser, or use the print settings application to add your printer.

You were 100% correct! I did as you suggested, installed cups and then started cups service and problem solved. Thanks a lot, really appriciate the help.

1 Like