[SOLVED]Tor-Browser not working

So I’m trying to get Tor-Browser working. But everytime i run the launcher i get this error:

Tor unexpectedly exited. This might be due to bug in Tor itself, another program on your system, or faulty hardware. Until you restart Tor, the Tor Browser will not able to reach any websites. If the problem persists, please send a copy of your Tor Log to support team.

I have anonsurf installed and it’s working really great. I’m only able to run Tor-Browser from Windows XP running in a virtual machine.

I’m running Parrot Security OS x64 bit.

I dual boot with Windows 10.

When I press the “Copy Tor Log to Clipboard” my clipboard saves ("") in it’s string.
Anyway that i can maybe uninstall tor, and reinstall it?
I’m new to ParrotOS.

Upgrade your system.
sudo apt update
sudo apt dist-upgrade

1 Like

Okay thank you, i’ll try doing it.

Palinuro create a good script for us.
sudo dist-upgrade

You can check it with cat /usr/bin/dist-upgrade. This small script upgarde the system perfectly :slight_smile:

1 Like

Like the problem happened to you once? or maybe a similar problem?
Or just a suggestion. Because i tried upgrading the system once with
$apt-get update
$apt-get upgrade
$sudo dist-upgrade
different from it?

Always use dist-upgrade

Read about here:

Yes, your problem with tor-bowser was a known bug, but it is solved

1 Like

This fixed the issue for me.
Thank you for your time.

1 Like

Sometimes it the simple stuff you overlook. Make sure the time and date and time zone are all set correctly or it will give an error and not work.