[Solved] Touchpad broken in Parrot 4.6

UPDATE: There is a full patch released now by the devs. Upgrade to the latest version to get the fix.

Briefly describe your issue below:

The touchpad doesn’t work after the latest update to 4.6.

What version of Parrot are you running? (include version, edition, and architecture)

Parrot GNU/Linux 4.6 x86_64

uname -a

Linux workstation 4.19.0-parrot3-28t-amd64 #1 SMP Parrot 4.19.28-2parrot3.28t (2019-04-14) x86_64 GNU/Linux

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Debian GTK

Configured to multiboot with other systems? (yes / no)


If there are any similar issues or solutions, link to them below:

Most similar

Debian Wiki Synaptics Touchpad

If there are any error messages or relevant logs, post them below:

Laptop is Dell XPS 15 9570 with synaptics trackpad

sudo dmesg | grep -i synaptics

[    3.197568] psmouse serio1: synaptics: Unable to query device: -5
[    8.893644] input: PS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input6

egrep -i 'synap|alps|etps|elan' /proc/bus/input/devices

N: Name="PS/2 Synaptics TouchPad"

Contents of /usr/share/X11/xorg.conf.d

drwxr-xr-x 1 root root  292 Apr 17 04:43 .
drwxr-xr-x 1 root root  104 Apr 14 16:27 ..
-rw-r--r-- 1 root root   92 Feb  7 13:19 10-amdgpu.conf
-rw-r--r-- 1 root root 1099 Aug 23  2018 10-evdev.conf
-rw-r--r-- 1 root root 1350 Oct 25 11:15 10-quirks.conf
-rw-r--r-- 1 root root   92 Feb  7 13:17 10-radeon.conf
-rw-r--r-- 1 root root 1429 Mar 30 18:56 40-libinput.conf
-rw-r--r-- 1 root root  113 Mar 11  2018 50-multitouch.conf
-rw-r--r-- 1 root root 1753 Aug 23  2018 70-synaptics.conf
-rw-r--r-- 1 root root 2747 Jun 26  2017 70-wacom.conf
lrwxrwxrwx 1 root root   50 Mar 25 22:40 nvidia-drm-outputclass.conf -> /etc/alternatives/glx--nvidia-drm-outputclass.conf

From what I’ve found online, this might be a conflict between xserver-xorg-input-libinput and xserver-xorg-input-syaptics, but it’s probably just because of the update to 4.6.

Copying everything from /usr/share/X11/xorg.conf.d except 70-synaptics.conf doesn’t fix the trackpad into /etc/X11/xorg.conf.d doesn’t seem to have any effect either.

Is there any way to fix this issue? Or should I just wait for the next update?

1 Like

Previously used any version of Parrot ???
Did you face this problem with other debian based linux ???

Can you please try to set with
Dconf editor

Because your report sims nothing wrong

1 Like

@Amzker, Yes seems that there is no problem but can be some configuration problem.

Yes. I was previously on parrot 4.5.1 before and the trackpad worked fine.

I’ve also had Debian Buster run with no trackpad issues.

1 Like

@mrb1ue think that you tried to customize your configuration files
Specially synaptics.conf files

What do i use dconf-editor to do?

How do I use it?

1 Like

@retardedCode Here’s the contents of 70-synaptics.conf. I haven’t touched it to the best of my knowledge.

# Example xorg.conf.d snippet that assigns the touchpad driver
# to all touchpads. See xorg.conf.d(5) for more information on
# InputClass.
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
# Additional options may be added in the form of
#   Option "OptionName" "value"
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
#       MatchDevicePath "/dev/input/event*"

Section "InputClass"
        Identifier "touchpad ignore duplicates"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/mouse*"
        Option "Ignore" "on"

# This option enables the bottom right corner to be a right button on clickpads
# and the right and middle top areas to be right / middle buttons on clickpads
# with a top button area.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Default clickpad buttons"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
        Option "SecondarySoftButtonAreas" "58% 0 0 15% 42% 58% 0 15%"

# This option disables software buttons on Apple touchpads.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Disable clickpad buttons on Apple touchpads"
        MatchProduct "Apple|bcm5974"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "0 0 0 0 0 0 0 0"
1 Like

try using dconf command
or see this :→

Are you using live boot ??? → seems you are not
seems there is no problem in the 70-synaptics.conf

Yes this is installed.

1 Like

use man dconf and read the instructions
try to boot in the live mode and see if the problem persists

I’m using kde btw. Are you sure dconf is relevant for my case? I’m looking through the man page and it looks like its only for gnome

I am also using KDE Environment, there is no problem in the touchpad drivres. Just try to boot in live mode and see if that occers
Tried via VM or not ???

Tested live with Parrot4.5.1_kde live. Touchpad works perfectly.

Like I mentioned in the OP, the touchpad stopped working after the update to 4.6.

No try 4.6 KDE Live as you have mentioned the problem occers in the Parrot 4.6

Which you are using ???

  • Parrot Home 4.6 RC8 KDE (Beta)
  • Parrot Security 4.6 RC8 KDE (Beta)

Try downloading from here → http://download.parrotsec.org/parrot/iso/testing/
Try Live Boot & see if the problem is fixed :smile:

Sorry, just took a lot of time to download.

Yes the trackpad works.

Tested on Parrot_sec_kde_4.6

1 Like

Happy to hear that your problem is solved :smile:

@retardedCode I mean the problem still isn’t fixed. Touchpad works fine on the live system, not my installed one.

I’m having the same problem. I’m using a ASUS VivoBook Max with Parrot 4.19.0-parrot3-28t-amd64. After i updated it, it was working just fine, but after a reboot, the touchpad isn’t even showing in the settings. Not even in the /proc/bus/input/devices

1 Like