[SOLVED] Won't boot kernel 4.16.0

Parrot Security 3.11 64-bit
Debian GTK install
Running in Virtualbox version 5.2.10 r122088 (Qt5.6.1) (base memory 2700MB, 40GB)

Updated to kernel 4.16.0-parrot5 amd64 and now system won’t boot (black screen, blinking cursor top-right)
Boots as normal from previous kernel, 4.15.0-parrot17 amd64.
Reinstalling reproduces problem.

(edit) After another update, 4.16.0-parrot5amd64 boot now leads to the repeated Stopped Light Disply Manager, Starting Light Display Manager, Started Light Display Manager, then simply doesn;t proceed. None of this is reproduced on a full usb install which loads 4.16.0-parrot5amd64 without problem.

No previous problems updating kernels.

LinuxMint 18.3 Cinnamon 64-bit
Cinnamon 3.6.7
Linux Kernel
processor - Intel Pentium CPU 2020M @ 2.40GHz x 2
Memory - 5.6GiB
Hard Drive 474.4 GB
Graphics Card - Intel Corporation 3rd Gen Core processor Graphics Controller
Graphics Card - NVIDIA CorporationGF117M[GEForce610M/710M/810M/820M / GT620M/625m/630M/720M]

What information should I provide?



416.0-parrot5 amd64 unable to boot after kernel update from 4.15.0-parrot 17 amd64
problem is blank screen and a blinking cursor.
am able to boot to previous kernel.
help me :slight_smile:


Get the guest additions for virtualbox 5.2.12 here https://launchpad.net/ubuntu/+source/virtualbox-guest-additions-iso/5.2.12-1

mount the iso and move the Linuxadditions.sh to the root directory
execute it and reboot
It should solve the problem

Same problem here. Same config.
Parrot inside Virtualbox VM. Blinking cursor after update to 4.16. (I still can log on with 4.15)

I can alt+F1 to get a shell.
Tried to reinstall guest additions (5.2.10 and 5.2.12) but it’s not working :

  • “Failed to parse arguments : Cannot open display”

Similar error when I “startx” :

  • “no screens found”

I have the following error at startup :

  • Failed to start Virtualbox guest utils

Everything is up to date and cleaned. It’s a fresh install + update && upgrade.

Any help would be greatly appreciated.

I’m not running Virtual Box but have the same problem…



I have the same issue. This not running on a VM. It is installed on a separate hard-drive. The issue is I can’t launch is sort of terminal either through recovery mode or older Parrot installation options.

Therefore I’m completely stuck and can’t do anything.