Some support, fix for python-faraday

Hi everyone! I’ve installed python-faraday for my Parrot and i am having some issue:

  1. Faraday asks me username and password, which i have no idea about it. I did a google search but i found nothing helpful. (Does anyone know its default username + password?). As i remember, previous version doesn’t require username + password (maybe i am wrong here).
  2. So i tried to create database. Running script manager.py in /usr/share/faraday/ with initdb command give me error messages and None object. python-farday db didn’t created.
  3. Firejail sandbox blocks python-faraday for opening web service. I can start python-faraday web service with firejail --noprofie but i really hope dev team will fix this profile soon.

What version of Parrot are you running? Parrot 4.2 amd64

What method did you use to install Parrot? Debian GTK

Configured to multiboot with other systems? yes

1 Like

Yeah you need to update the password in the database. Follow these steps, they should get you there: https://github.com/infobyte/faraday/wiki/Install-steps-for-Faraday-v3.0

To avoid using --noprofile you will have to create a custom profile (It can just default allow). Here are the steps to do that: https://firejail.wordpress.com/documentation-2/building-custom-profiles/

Thanks for your supporting. Username and password is the new feature in faraday 3 i guess? I gonna give a try. But, as i said, creating database gave me error (None object) so i must figure it out.
Thanks again.

I installed new database. faraday is still having this error (I can logged in). Looks like firejail blocked some path (libs path?).

May well be. Try with --no-profile, if that works make a custom profile for it.

I tried. It is still 500 error. But i gonna do a test carefully in this weekend.

having this issue now…I would really like to be able to use faraday once again.

Really? it runs fine for me. Are you sure you are on latest parrot and you have no sandbox?