Sound Issue on Parrot 4.9 MATE

Hello Everyone:

I am a new user and i installed Parrot OS 4.9.1 MATE version on my laptop. This is the only operating system on my laptop.
After installation , when i try youtube, i do not have any sound.

I tried:
lspci | grep -i audio and the output is attached.

Please help.

1 Like
  1. Firstly, Reload Alsa
    $ sudo alsa force-reload

  2. Reinstall Alsa and PulseAudio

$ sudo apt remove --purge alsa-base pulseaudio
$ sudo apt install alsa-base pulseaudio

  1. Reload ALSA again and reboot your computer.

try

or
Additional Kernel Boot Parameter
first go to /etc/default/grub then add snd_hda_intel.dmic_detect=0 to GRUB_CMDLINE_LINUX_DEFAULT= after quiet splash then save it and run sudo update-grub then reboot the system and check if it is working or not ,if it works keep it else you can remove this.

it should look something like this:
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash snd_hda_intel.dmic_detect=0"
*however it may vary if there are any additional commands

1 Like

As prasandeep69 said, it may be that PCM or the Pulse control module itself is at the root of problem, forcing the reload, and reinstalling both alsa ( advanced Linux sound architecture )
and pulse may not be necessary. from the terminal run alsamixer F6 to select the output device in question if it is not the default, and i have found that quite often when presented with no sound, that PCM is simply turned off and/or turned all the way down. turning it on and raising the volume in alsamixer often does the trick. Don’t forget to run sudo alsactl store after exiting alsamixer, if it does fix the problem, in order to save the changes or else you will be right back where you started on next boot.

I tried to install alsa-base. Here is the output:

Please help.

I tried sudo alsactl store and no sound card found. Here is the output:2

Please help.

Thanks.
The problem is solved with the procedure you described.

Thanks a lot again.

Good to here :smiley:

I have same problem after remove alsa-base package,