SSTP-Client missing libc6 version 2.34 (Unmet Dependecies)

Hey everyone!

I’m trying to get SSTP-Client installed so I can connect to my work VPN from my Parrot boot.
I followed the steps in this repo: GNOME / network-manager-sstp · GitLab

My output when trying to install (and uname for distro information):
https://pastebin.com/m1Zha06T

I’ve tried looking around for a higher version than currently installed but I can’t seem to find one that works.
Anyone have an idea that could help me out?
Or an alternative that might work better?

Hi @z3fq0n. The directions on the GitLab page has users adding this to their sstp-client.list:

deb http://ppa.launchpad.net/eivnaes/network-manager-sstp/ubuntu impish main

Have you tried changing impish to some older Ubuntu version like Focal?

deb http://ppa.launchpad.net/eivnaes/network-manager-sstp/ubuntu focal main

http://ppa.launchpad.net/eivnaes/network-manager-sstp/ubuntu/dists/?C=M;O=D

Hi @Masmer . Thank you for the suggestion.
I have tried changing it to all the versions in the link you send.
Whenever I use any other version than impish (focal included) I get and error that my PPP package is too high of a version. Whenever trying to downgrade that manually it errors out too about it breaking my network-manager.

The error about the ppp version:

It seems I either have to wait for the proper libc6 version to be released or just don’t work from home :frowning: .
Thanks for the help!