Static DNS Parrot OS


(Walid) #1

I was trying to set a static DNS in Parrot OS Sec, and i got some problems, the issue was that the /etc/resolv.conf file was not a symbolic link to /etc/resolvconf/run/resolv.conf
So all my requests were not using my static dns set by network manager :cold_sweat:
Solution :
sudo rm /etc/resolv.conf
sudo ln -s /etc/resolvconf/run/resolv.conf /etc/resolv.conf
sudo service network-manager restart
And it worked ! :heart_eyes::heart_eyes::heart_eyes:


#2

or you just add your nameserver you want and you comment all the other and the rotate options in /etc/resolv.conf… more simple and you have all dns in case you want to revert your DNS settings…


(Walid) #3

The problem with the /etc/resolv.conf file is that it restets after reboot. so i did not want to touch it or edit it. that’s why i searched for other solutons.


#4

wtf no no and no… this file dont reset after reboot… and i know that because i dont use the default dns in parrot and use mine personnal dns!!!

What is the problem with noob like him post some odds “solutions” and when we say them they are wrong they insist in the bad way??? please admin and moderators, this distro dont need to have post like that on the forum for the sake of ParrotOS!!! go on kali Simyc!!!


(Lorenzo "Palinuro" Faletra) #5

/etc/resolv.conf is handled by the resolvconf daemon

if the /etc/resolv.conf symlink is removed and replaced with a standard file, then the changes would persist after a system reboot, but networkmanager would be completely unable to set the dns server pushed by the dhcp server, which is a good thing for a server but a terrible idea for a portable device like a laptop.

the solution found by @symic is a very good solution and it is the official solution that i, as the parrot team leader, would have suggested tovsomeone with dns resolution issues

/etc/resolv.conf is supposed to be handled by resolvconf in parrot

if you need to configure your own dns servers, then just edit the files under /etc/resolvconf/resolv.conf.d/, but avoid replacing the /etc/resolv.conf symlink with a regular file


(Nico Paul) #6

That’s the beauty of building your distro… its YOUR distro. Thanks for all the hours you put in Palinuro! Grazie mille!


(dmknght) #7

This is genius idea. My resolv.conf was added a LAN IP before and i think it is stupid.


(Lorenzo "Palinuro" Faletra) #8

it has nothing to do with what i want to do, it is all about how standards work and how other distributions standardize their internals


(Nico Paul) #9

Absolutely, and countless hours of workarounds and configurations!


#10

if you modified /etc/resolv.conf (which isnt a symlink on my distro and i never replace it myself with a standard file on my ParrotOS security) it was never be replaced on the reboot for me, and i have no problem with every dhcp server.


(Lorenzo "Palinuro" Faletra) #11

if you have a static resolv.conf that ignores the suggestion of dhcp, then you are ok on most of the networks

there are some networks where dns traffic is forbidden and only one server (the one suggested by dhcp) is allowed to receive dns traffic

a static resolv.conf is probably going to give connection problems on such kind of restricted networks


Resolv.conf Configuration for dns
#12

You about a dns server in domain?? i hope not


#13

what do you change since the last update because now i have no static dns whatever method described here…


#14

The DNS Servers listed in my resolv.conf.d, do not match the DNS Servers listed when I open “Connnection Information” on my network interface. Why is that? My network interface still lists my router as primary dns, and the dns servers I added as secondary.


#15

Here’s what I’m talking about. I don’t understand this, My primary DNS is always listed as my router.




(Matt) #16

The first three in your case are DNS servers provided by your dhcp server. The last three provided by Parrot.

Your router will be forwarding your DNS requests to your ISP’s dns (unless configured otherwise). You should be able to see those server IP’s in your router settings.

If you want help configuring your resolv.conf file, create another thread and i will help you there.


#17

Thank you.