Steam libraries on Parrot 5

Hi, I am trying to install steam on the new Parrot 5, it worked transparently on 4 but here it yields:
libgl1-mesa-dri:i386
depends:
libvulkan1:i386 (>= 1.2.131.2)
steam-libs-i386:i386
depends:
libudev1:i386 or libudev0:i386
reccomends:
libasound2-plugins:i386
mesa-vulkan-drivers:i386

Hi @Owein

Have you already added the i386 (Multiarch) architecture to apt sources?

sudo dpkg --add-architecture i386

Yes thank you actually this is what is needed to do, but the libraries must be installed on by one by hands and some like ‘libudev’ must be rolled back (i picked those from ubuntu 20.04 on ubuntu.packages)
It was alltogether quite complex and risky to install steam and so I switched to ubuntu.

Sorry it didn’t work out smoothly on Parrot.

If you haven’t tried already, you could use Steam via Flatpak (suggested) or via Snap on Parrot.

https://flathub.org/apps/details/com.valvesoftware.Steam

https://snapcraft.io/steam

Do you have any error log? i’m using steam right now on parrot. haven’t seen any problem so far
p/s: full output of apt error log will be good

The problems were with missing uninstallable libraries, when you first run steams it installs those it needs. At that point i’m not sure it does dpkg --add-architecture i386 by itself so maybe running that before steam. But sure it was broken at one point. I’ll try it again soon and will come here to report if anything goes wrong again.

Add architecture is correct. DId you try sudo apt install steam:i386 -t parrot-backports?

No, i did not know about that option. But if you installed it without issues then I guess I tried it at some point in time where there were incompatibilities.

Well I installed it long time ago. The point i asked you to show full error log of apt is to spot which package could make the error.

Ok i got the solution, from a clean Parrot 5 install.
dpkg --add-architecture i386
apt update
apt install libudev1:i386 libgl1-mesa-dri:i386 -t parrot-backport

Steam will install all it’s dependencies after that.
Thanks for your help.

1 Like

well to be fair that’s our problem that didn’t maintain default branch properly. I hope we can improve this later. Our model is making real troubles for us

Okay, thanks for keeping this system operational it’s the best I could find even for gaming it’s more stable than ubuntu.