Struggling to boot Parrot on mac OS from USB

Hi everyone,

I’ve been trying to boot the Parrot Security edition from a USB stick on my MacBook Air for a while now (I’ve also tried in the past with Ubuntu) but it fails every time. I’ve tried so many different things. My security settings have been updated to allow this and I’m able to select the boot device. I’ve downloaded the most recent iso from Parrot (using the mirror from MIT as Parrot’s own download link returns a 502). I then etched it onto a newly reformated USB stick, which was successful. I’m able to select the stick when booting up, and even get to the first page where I’m able to select “Try/Install” and then it fails from there. When trying to install Ubuntu, I tried partitioning as well, but that failed, so I didn’t bother for Parrot (partitioning has since been removed).

  • ParrotOS iso in use:
    Parrot-security-4.11.3_amd64.iso

  • Application used for flashing the iso:
    Balena Etcher

  • Logs/Terminal output (use pastebin or similar services):
    Was unable to take a screenshot of the error, but I took a photo and copied down what the log said (mostly cause my reflection is in the image lol). This is abridged, but this is the general error.

(AE_NOT_FOUND) {202110604/papEAW-529)
[  0.224709] ACPI BIOS ERROR (bug): Could not resolve symbol [\_SB.OSCP], AE_NOT_FOUND (20210604/psargs-330)
...
[... ACPI Error: Aborting method \_PR.CPU3._PDC due to previous error AE_NOT_FOUND ]
DMAR: Failed to find handle for ACPI object
Integrity; Couldn't get size
Integrity: MODSIGN: Couldn't get UEFI db list
Integirty: Couldn't get size
Intel-lpss INT344R:00: IRQ index 0 not found

Not sure if anyone can help. At this point, I’m resigned to using a virtual machine but that isn’t ideal for trying to practice/learning pentesting and I can’t exactly go buy a non-mac computer (the air is actually my spare so I don’t have to worry about messing something up).

Hi. What model of Macbook Air is it? Any Macbook after 2015-2016 does not allow the installation of a GNU/Linux system. You can only use it in VM.

Oh no, really?! I had no idea. It’s a Macbook Air 2018. I do have another old, on-its-way-out Macbook from 2012 – I should be able to run Parrot off a USB on that one, right?

I never tried that, but you can consult the Debian website (for Parrot it will be the same): InstallingDebianOn/Apple - Debian Wiki

Cool, thanks so much for your help!