Stuck in the login loop

Whenever bootup parrot os and fill up the password. Screen blinks and comes back to the same login display. Diplay is stuck in the login loop.
Changed password and tried to logged in but failed.
Also tried grub fixes but nothing worked.

Parrot version 4. kde plasma security in dual boot with windows 10.
Installed using bootable USB Debian Standard…

Configured to dual boot with Windows 10.

1 Like

likely your .Xauthority file (in home directory of user you are attempting to login) had its ownership changed somehow.

  1. Get yourself to commandline using ctrl+alt+f1

  2. Login

  3. sudo Chown UserNameHere /home/UsernameHere/.Xauthority 
    

This will change ownership giving you permission to start X windows.

If this doesn’t work let us know.

1 Like

I tried this but didn’t work.

Hi guys, I’ve been using Parrot Home since last couple of months. It was working fine until I decided to do a fresh installation. Ever since after installation, I’m not able to login into Parrot. I keep getting redirected to the login screen even after entering the correct password. Like an endless loop. Kindly help me with this. Here are the relevant information regarding my Parrot OS:

1. Your Parrot information

  • OS version: run cat /etc/*release
    DISTRIB_ID = Parrot DISTRIB_RELEASE = 4.10 DISTRIB_CODENAME = rolling DISTRIB_DESCRIPTION = Parrot 4.10 PRETTY_NAME = "Parrot GNU/ Linux 4.10 NAME = "Parrot GNU/ Linux" ID = parrot ID_LIKE = Debian VERSION = "4.10"
  • Kernel version: run uname -a
    Linux parrot 5.7.0-2parrot2-amd64 #1 SMP Debian 5.7.10-1parrot2(2020-07-31) x86_64 GNU/ Linux

2. If you have this problem after fresh installation:

  1. How did you create USB bootable?

    • Software was used to make USB: I used Balena Etcher to flash the ISO image into flashdrive.
  2. How did you install OS?

    • GTK Installer from bootable Flash Drive.

Hardware information

- Your device name or output of `lspci`
```
 Device Name: Acer Nitro 7
```
- Did you try searching info about this issue on search engine? 
 - Yes I tried the most of the solutions listed on (https://askubuntu.com/questions/223501/ubuntu-gets-stuck-in-a-login-loop). None of it seem to work.

4. How did you get this error? Are there any steps to procedure it?

1. I got this error after freshly installing Parrot OS.

5. Error log or screenshot

** Insert error log and screenshot here**

6. If you have any idea or suggestion about this issue please tell us

** I believe it has to do something with gdm/ lightdm(idk?). I think so, because in my previous version of Parrot I was tinkering with gnome 3 installation and such. Could’ve broken something? Also, the problem could be due to the presence of older Parrot OS kernels? I’m a newbie to Linux. That’s all I could possibly infer. **

I moved your post to the open “Stuck in the login loop thread.” We have a few threads on this topic, and 99% of the time, the above solution will fix it (if performed correctly- be sure to replace 'UserNameHere part with your Parrot system’s username).

Please be sure to search for open threads on the topic (replies send it back to the top for viewing).

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.