sudo apt-get update error

parrot

(SUPRODIP BHATTACHARJEE) #1

i am trying hard to update my system which is parrot but i am unable to do that
when i type sudo apt-get update , these are the following errors come

E: The repository ‘http:/deb.torproject.org/torproject.org stretch Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

please help me i am in serious problem


(Ja Roslaw) #2

use VPN if you can.


(Kilian) #3

Hi, did you add custom repository ? If so this is a really bad idea, i suggest you go back to the standard parrot repository, to do so follow the official documentation:

https://www.parrotsec.org/docs/mirror-list/

Ps:

The error he received has nothing to do with vpn.


(Ja Roslaw) #4

Problems with respository after todays updates m8.

E: The repository ‘http://deb.parrotsec.org/parrot parrot Release’ no longer has a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.


(SUPRODIP BHATTACHARJEE) #5

i have done this very before but still it did not get updated


(SUPRODIP BHATTACHARJEE) #6

please help me to update my repository ,i really am demotivated my this problem even i was thinking to switch to kali linux . let me see this week if this problem does not get ok then i will surely updated my system to kali linux


(Nico Paul) #7

Well first of all you’re not using the correct command as the documentation instructs you to use

parrot-upgrade

But also it qppears that if you gave previously selected to use the deprecated mirror-selector pkg it will redirect you and call for https (you DO NOT need to use https and it DOES NOT mean it will be any more secure or safe) so edit your sources.d/parrot.list to be http.


(SUPRODIP BHATTACHARJEE) #8

hey man i searched on net how to add repository ,and i got something to type command on my terminal and now when i do sudo apt-get update,i get this error

E: Type ‘new’ is not known on line 7 in source list /etc/apt/sources.list
E: The list of sources could not be read.

help me please


(Kilian) #9

Why did you read online how to add repo ? Look in parrot documentation and by the way, adding repo is a really bad idea.


(Nico Paul) #10

Did you check this site at all? Adding a repo or changing will break your parrot in many unkown and unpredictable ways


(SUPRODIP BHATTACHARJEE) #11

hey bro this error is fixed now i am again getting the previous error

E: The repository ‘http:/deb.torproject.org/torproject.org stretch Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.