System freezing after last upgrade

Hello.

After i did apt upgrade today, my system started to freeze in random moments, or when I tried to do something a little bit more challenging than commands in terminal. One time even moving a cursor on desktop was enough for it to freeze. There is no way to unfreeze it, but to shut it down manually by the power button. I have already tried reinstalling the system. Before I did upgrade everything went smoothly, but after that problem appeared again. I have no idea what do do, maybe some package update has got a bug that causes freezing?

Specs:

Kernel: 5.14.0-2parrot1-amd64 x86_64 bits: 64 Desktop: MATE 1.24.1 Distro: Parrot OS 5.0 (LTS)

CPU: Info: Quad Core model: Intel Core i5-1035G1 bits: 64 type: MT MCP cache: L2: 6 MiB
Speed: 1166 MHz min/max: 400/3600 MHz Core speeds (MHz): 1: 1166 2: 1101 3: 1100 4: 1100 5: 1100 6: 1105 7: 1146 8: 1109

Graphics: Device-1: Intel Iris Plus Graphics G1 driver: i915 v: kernel

Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting unloaded: fbdev,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 20.3.5

How much memory does your (laptop) have? I would first run

htop

to see what is eating the memory and/or CPU. Probably a web browser.

I have 12 GB of ram, but I don’t think it’s the problem. Average memory use is 9%. Today my system has freezed from just having system monitor open. I suppose there can be a problem with some additional graphical drivers that are installed with the first apt upgrade. As I said, there was no problem before I upgraded my system. Also I have noticed, that when my computer freezes, fan starts to work at full speed and laptop is getting very hot. SysReq does not work.

1 Like

Hey mikinis,

I am having the same issue after the latest Parrot Os upgrade. I am using the Parrot Home version, with 8 GB RAM, 100 GB partition for Parrot OS in my HP notebook. The entire OS freezes when I just do something like using terminal or open two tabs in firefox. I waited for almost 15 mins and only the shutdown by powerbutton seems to work. Later when I restart, the same freezing issue occurs. I have been a user and fan of Parrot OS for 4+ years, I haven’t faced any issue like this one and it is frustrating.

And on the latest update I got the following error.

Loading new virtualbox-guest-6.1.22 DKMS files...
Building for 5.14.0-2parrot1-amd64
Building initial module for 5.14.0-2parrot1-amd64
Error! Bad return status for module build on kernel: 5.14.0-2parrot1-amd64 (x86_
64)
Consult /var/lib/dkms/virtualbox-guest/6.1.22/build/make.log for more informatio
n.
dpkg: error processing package virtualbox-guest-dkms (--configure):
 installed virtualbox-guest-dkms package post-installation script subprocess ret
urned error exit status 10
Errors were encountered while processing:
 virtualbox-guest-dkms
Scanning application launchers
Removing duplicate launchers or broken launchers
Launchers are updated
E: Sub-process /usr/bin/dpkg returned an error code (1)
failed to fix conflicts

All we can do is hope that this will be fixed in upcoming update!

Hi

Are you running Parrot inside a Virtual Box guest?

No, I just dual boot it along with Windows 11. SInce I have an i3 processor , it would be pretty much bad if I use virtual machine. I just downloaded the following,

Download ParrotOS Home Edition → Mate desktop → Get torrent

I downloaded torrent and created USB live and installed using it. After installation there was no issue in the OS as it worked fine. But when I used “sudo parrot-upgrade” it showed the mentioned virtualbox-guest-dkms error and started crashing.
I have also noted that the fan speed is higher when parrot OS froze.
I have created USB live using Balena Etcher.
Please find the iso file details I have used.

I think others are facing the same issues too similar to mine as shown in below link.

In my case it was virtualbox, in the above it was gnome-icon-theme.

That’s strange. The virtualbox-guest-dkms is only needed if Linux is running in a virtual machine as a guest. The developers might have added the package for those running Parrot on a VM and now the latest virtualbox-guest-dkms is causing an issue on bare metal installs.

Can you purge the package?

sudo apt purge virtualbox-guest-dkms

Hi Masmer,

I have used the following code and it removed the virtualbox-guest-dkms from Parrot OS. Let me reboot it and check once.

sudo apt purge virtualbox-guest-dkms

It works, the error is removed. But the fan speed is still higher when using Parrot OS.I am afraid it might freeze any minute.

Updated : Still experiencing the OS freezing issue. I just log in, open any application or terminal. Then the OS freezes.

Just want to add, that I’m also working on HP notebook.

Hi Mikinis,

I think this has something to do with HP notebook BIOS update. I have disabled the Virtualization Technology which was newly added and enabled after the BIOS update. Try disabling it in BIOS setup and give Parrot OS a try. Mine is working fine after doing so.

f10 → Configuration tab → Virtualization technology (disable it)

Now reboot your system and use Parrot OS.

Hi
After disabling VT and rebooting, the freezing problem still occurs.

I think maybe you should try reinstalling the parrot OS once and update it. Please also ensure that Virtualization Technology is disabled before reinstalling the OS.

Alright, I’m going to reinstall once again when I’ll find some time and then, I’ll tell you results.

Reinstalled the system and upgraded. Problem still occurs.

Edit 1
After 2 reboots, system working perfectly fine for 20 minutes. I’ll write if it freezes again.

Edit 2
Nevermind, it still freezes.

Yeah, I am facing the freezing issue again. I think all we can do is wait for another update with a fix for this issue.

If nothing happens tomorrow, I’m just gonna switch to ubuntu. I need my notebook working, one way or another.

Yeah, I tried Fedora. It is having the same issue, installed it, updated, then rebooted and it started freezing again. I believe it has something to do with my Windows 11 update along with BIOS update. Crap, I hate windows even more now. Let me know if you find anything working.

Edit: It seems like this issue is in all linux distros when updating above Kernel 5.10.

1 Like