System unusable because of DNS resolving error

Briefly describe your issue below:
Hi, i’ve just installed Parrot OS for studying web security but the thing seems really difficult because of the extremely frequent networking problem of this OS. This problem seems affect the DNS resolution process, in fact, when trying to ping a casual server it returns “temporary DNS resolving error” and the only solution that works is restarting the system which is pretty annoying because the problem shows up casually while using the OS and not in “specific moments” like at startup or when starting Firefox. I’ve already tried adding the dns-nameserver string in /etc/resolv.conf but doesn’t work; tried disabling the NetworkManager service (which should be the responsable of resolv.conf’s auto-edit. If someone can help me fixing this i’ll be really grateful.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
I’m running Parrot Security OS 4.6 amd64 on a VMware virtual machine. 8gb of RAM, 4 cores and 30gb of storage dedicated to the machine
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
I’ve installed Parrot using the iso os image and launched it from VMware
Configured to multiboot with other systems? (yes / no)

List your networking hardware (make, model, firmware version):
The machine is working in NAT with the host system which has a TP-Link TL-WN881ND network card (don’t know the firmware version, sorry)
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Hello @qweqwe :slightly_smiling_face:

Could you share your current data in file /etc/resolv.conf

Also, Clear everything in that file & Try adding these lines [as sudo], save the file, reboot.


Let us know how it goes!

1 Like

Hi, thank for the advice, i’ll try.
The resolv.conf actually contains these 3 lines:

search localdomain

Is that your AP?

Sorry for my unexperience, how do I check that?

Ok, i’ve tried writing those two lines, after rebooting the file return to original status and the connection works, after about 30 minutes (when using DVWA that’s hosted in another VM) the message “you must login to this network ti navigate in internet” appears, skipped that and the dns resolv error returns. Could that message be related to the error?

qweqwe Mark
i had the same issue and everything was fine in resolv.conf my whole issue was the system clock it happens everytime i do a fresh install make sure your clocks are accurate and system time/date are set properly

1 Like

I wish I could tell you why, but yes… this worked when i experienced this problem as well.

It seemed It was working fine…but the problem showed again, clock Is now set well and also disabled the http basic auth in dvwa’s folder but the problem Is still there

1 Like