T530 Thinkpad Trackpad isn't working?

– Please Write here your help request, –
I just installed the latest parrotos version on my T530 since I now daily a mac. I have had intermittent trouble with this thing on linux since one of the kernel updates but it’s always randomly worked for a bit/I’ve used a mouse. I’d like to make this a machine I practice/learn on in bed and not have to bring a mouse. Would greatly appreciate the help.

  • Parrot version in use (if you are not aware of it, open terminal and type cat /etc/os-release | grep VERSION):


  • Kernel version (if you are not aware of it, open terminal and type uname -r):


  • Logs/Terminal output (use pastebin or similar services):

  • Screenshots:

Or these:

I would try to look in these and see if any help.


Hi Alexander,
I have the same machine which I also use to ‘Play On’.
When you boot up your lappie press return to access Bios menu, Hit F1 at the next page.
When the Bios setup opens Tab along toConfig. Hit Return, then down arrow to Keyboard/Mouse and Hit Return. You should see Track point and Touchpad. Arrow down to the one you want and then Return again to select enable.
Once you have enabled them both press escape and tab along to save settings ,Return ,Yes to save changes and the your machine will reboot to your new settings.


1 Like