Temporary failure in name resolution problem

– Please Write here your help request –
OK, what is happening with names resolution inside this OS? Managed to fix it. Worked fine for some time and now it’s same issue all over again.
Had Kali, Ubuntu, Debian 10 on this machine and they all worked and work without a single problem. Only Parrot OS keeps throwing the “Temporary failure in name resolution”. I don’t get it. I’ve done everything properly and nothing changed.

  • Wireless drivers are fine
  • Network configuration is fine and didn’t change
  • Nothing has been installed
  • No resolver configuration was messed with
  • AnonSurf was working fine and the clearnet after it also
    I just don’t get it. I like this OS and planned to keep using it daily but this is a huge problem.

  • Parrot version in use (if you are not aware of it, open terminal and type cat /etc/os-release | grep VERSION):
    4.11

  • Anonsurf running? (yes/no)
    No

  • Logs/Terminal output (use pastebin or similar services):
    Just throws “Temporary failure in name resolution”. I know it’s the DNS resolver issue.

  • Screenshots: