Temporary failure resolving 'deb.parrot.sh"

Briefly describe your issue below:
I did an update and cant use apt-get anymore I get Temporary failure resolving 'deb.parrot.sh" everytime I try and download something

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
4.7
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
usb
Configured to multiboot with other systems? (yes / no)
no
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:
Err1 https://deb.parrot.sh/parrot rolling/main amd64 gyp all 0.1+20180428git4d467626-3

sudo anonsurf start && sudo apt update

Diagnosis Q

  1. Are you from India?
  2. Does internet working?

Nope not from india and after restarting it fixed itself. Thanks

Not sure why that was relevant with regards to “Diagnosis Q”. Pardon me but I’m not aware of any restrictions in south east Asia that affect Connections to Parrot or its mirrors.

Also, Updating parrot over Tor mostly is a bad idea. Many a times mirrors wont accept Tor connections so most package updates fails [From my personal experience].
Speeds getting significantly low is another issue of updating via tor network/anonsurf :slight_smile:

  1. Make sure your internet is connecting. Try ping 8.8.8.8 -c 4 and see if the response is okay
  2. If response is okay, check /etc/resolv.conf
  3. If the resolv.conf is empty, you can add DNS into the file or run sudo anonsurf dns

I have this problem and I’ve checked it isn’t my internet

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.