Terminal input - wrong characters

parrot
(Павел Шаманов) #1

Hi,
I’m facing the following issue and since I’ve spent already so much time on it, I’d like to ask for some help.

When I open a terminal (like tty1 etc.), I can’t make it display characters from my national alphabet (that is Czech) as you can here on this picture:
Screenshot%20at%202019-04-28%2015-13-47

Then, I have the following settings:
/etc/default/locale:
LANG=en_US.UTF-8
LC_CTYPE=cs_CZ.UTF-8
LC_IDENTIFICATION=cs_CZ.UTF-8

/etc/default/keyboard:

KEYBOARD CONFIGURATION FILE

Consult the keyboard(5) manual page.

XKBMODEL=“pc105”
XKBVARIANT=""
XKBOPTIONS=""
XKBLAYOUT=“cz,us”
XKBOPTIONS=“grp:alt_shift_toggle”

BACKSPACE=“guess”

/etc/default/console-setup:

CONFIGURATION FILE FOR SETUPCON

Consult the console-setup(5) manual page.

ACTIVE_CONSOLES="/dev/tty[1-6]"

CHARMAP=“UTF-8”

CODESET=“Lat2”
FONTFACE=“TerminusBold”
FONTSIZE=“8x16”

VIDEOMODE=

The following is an example how to use a braille font

FONT=‘lat9w-08.psf.gz brl-8x8.psf’

>locale gives the following output:
LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE=cs_CZ.UTF-8
LC_NUMERIC=“en_US.UTF-8”
LC_TIME=“en_US.UTF-8”
LC_COLLATE=“en_US.UTF-8”
LC_MONETARY=“en_US.UTF-8”
LC_MESSAGES=“en_US.UTF-8”
LC_PAPER=“en_US.UTF-8”
LC_NAME=“en_US.UTF-8”
LC_ADDRESS=“en_US.UTF-8”
LC_TELEPHONE=“en_US.UTF-8”
LC_MEASUREMENT=“en_US.UTF-8”
LC_IDENTIFICATION=cs_CZ.UTF-8
LC_ALL=

>localectl status returns:
System Locale: LANG=en_US.UTF-8
LC_CTYPE=cs_CZ.UTF-8
LC_IDENTIFICATION=cs_CZ.UTF-8
VC Keymap: n/a
X11 Layout: cz,us
X11 Model: pc105
X11 Options: grp:alt_shift_toggle

/etc/environment is empty

I have no additional settings in ~/.bashrc or ~/.profile
I’ve tried to change some of these files, like setting LC_ALL=cs_CZ.UTF-8
I’ve tried to change the settings using: >sudo dpkg-reconfigure console-setup
I’ve searched for solution elsewhere or even here, but no luck with any of the advice (mostly about changing LC_ALL and dpkg-reconfigure) I’ve found.
I have no problems with locale in pty, so I guess there is some other configuration of the desktop environment that play its role.

So, how should I go about it so I can see letters from the Czech alphabet in terminal?

(Павел Шаманов) #2

Alright, I read the man pages and simple setupcon (“In order to activate the changes on the console, run setupcon(1).”) did it, although the changes were lost after reboot. But until I find a better solution, I put setupcon 2>/dev/null into my ~/.bashrc. Now the console works with the desired characters :slight_smile:

1 Like
#3

Reading is important! :+1: Glad you found a solution!