The detected media cannot be used for installation

Dear Parrot community,

I try to install Parrot OS Home as Dual Boot with Windows 10 on my HUAWEI MateBook 13 AMD 2020 (which rely on a 256 GB Samsung SSD disk).
I’m facing an issue after selected language and local: the detected media cannot be used for installation. By browsing the internet, I only find topics about CDROM issues, but this is not my case. And maybe this is more a Debian issue than a Parrot issue…

1. Your Parrot information

Version: 4.11
Desktop Environment: Mate
Edition: Home

2. How did you get this error? Are there any steps to procedure it?

I first created a USB boot device with Etcher (on Windows 10) by flashing Parrot-home-4.11_amd64.iso, as recommended by the documentation. The computed SHA1 hash of the downloaded ISO file is identical to the one here: https://download.parrot.sh/parrot/iso/4.11/signed-hashes.txt (099bbf7813863b32dc5d1b74edb350985939d3ae)

I obviously had to disable Secure Boot on BIOS configuration by pressing F2 at startup (Product Name : HN-WX9W, BIOS Version 1.13). Then, by pressing F12, I choose to boot on the EFI USB Device detected.

Everything is going fine until the installer try to mount the USB device:

Detect and mount installation media.
Incorrect installation media detected.
The detected media cannot be used for installation.
Please provide suitable media to continue with the installation.

A solution I found in my researches was to flash USB device by using Rufus in DD mode: the problem still occurs.

I opened a shell (BusyBox v1.30.1) to investigate the issue and used the few commands I get (I can’t load other tools from debian-installer since the installation media… is not mounted):

blkid:

/dev/nvme0n1p1: LABEL="SYSTEM" UUID="8040-A40F" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="e6034020-3909-497a-b7df-cbe6fbb61764"
/dev/nvme0n1p3: LABEL="Windows" UUID="4E6C41136CD40F6ED" BLOCK_SIZE="512" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="1105ecac-e085-41d7-b7b1-2db61e5bdde9"
/dev/nvme0n1p4: LABEL="Data" UUID="BC2C417C2C413326D" BLOCK_SIZE="512" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="107ed68b-4f18-45fe-Bd23-3df26a4a66e9"
/dev/nvme0n1p5: LABEL="WINPE" UUID="1641-542A" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="Basic data partition" PARTUUID="e61c142f-2dbf-4465-820f-0a0fe04f4f97"
/dev/nvme0n1p6: LABEL="Onekey" UUID="94EE4388EE43619A" BLOCK_SIZE="512" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="4da79b64-91b2-479e-8fe4-616d92819aa5"
/dev/nvme0n1p7: LABEL="WinRE" UUID="962C458B2C4566F9" BLOCK_SIZE="512" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="7329ac9e-a5bd-40ff-8794-f355d0bc33a3"
/dev/sda1: BLOCK_SIZE="2048" UUID="2021-03-28-01-03-38-00" LABEL="Parrot home 4.11" TYPE="iso9660" PARTUUID="c2e6c839-01"
/dev/sda2: SEC_TYPE="msdos" UUID="BBF7-SEF2" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="c2e6c839-02"
/dev/nvme0n1p2: PARTLABEL="Microsoft reserved partition" PARTUUID="acc5960e-180c-4e5e-b1f0-de469ee31006"

As mount told me, the only partition disk mounted is /dev/nvme0n1p1 which is mount on /media… I don’t know why.
mount (truncate for the relevant data, I cut tmpfs partitions):

/dev/nvme0n1p1 on /media type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,locharset=ascii,shortname=mixed,utf8,errors=remount-ro)

I don’t know it’s a good idea but I tried to mount /dev/sda1 on /media/usb (/media/usb was already created, but I think I created it manually, not sure the directory was there at the beginning, but this was before I understand that /dev/nvme0n1p1 was mounted here):

mount -t iso9660 /dev/sda1 /media/usb
mounting /dev/sda1 on /media/usb failed : no such device

Why does the /dev/nvme0n1p1 is mounted by default on /media?
Why can’t I mount /dev/sda1?
What is the /dev/sda2 msdos partition on my USB device?
Did I miss something?

Thank you for your help :slight_smile:

1 Like

I had the same issue, but still didn’t find a solution … thanks for reporting so well about this issue!

I am facing the exact same thing and find nothing on the web to help

1 Like

When you create an installation media, Etcher creates 2 partitions:
a small partition with boot informations and efi (for uefi systems)
a bigger partition with the OS data
I don’t remember atm which one is the msdos partition.

/dev/nvme0n1p1 is a partition of your laptop’s ssd nvme m2, and it corresponds to MS windows boot informations. It’s mandatory for windows since without it, it won’t boot.

try to use an older version of etcher.

Balena Etcher version 1.5.0 does not work as well.

Why to use an older version @tissy ?

I found out that sometimes it fails to flash the iso, even if everything is okay. So, using an older version solved the issue and i try to suggest this to pepole having issues.