The network connection has been disconnected

Briefly describe your issue below:
I just ran the latest update and as before, I am able to select my wifi network from a list but after I click on it, it waits a few seconds then says Disconnected - The network connection has been disconnected. I have a usb belkin wireless network adaptor which was working fine before the update.


is anon surf running still by any chance or anything like that tor or a vpn?

Have you tried re-authenthicating to the router? singing in again?

if none of that works do you have an enthernet cable to test you have internet?

no one changed your router settings did they? are you the only person with access to it?

I’m just trying to bang out easy to check/verify stuff so it doesent have to be addressed again

By the way Welcome!~~~~

if you tried all these do you have another OS to spin up like Debian or Ubuntu just to verify internet is working normally?

1 Like

Hi thank you. I have tried all those things. Internet is working with network cable. I tried update and install driver for belkin network adaptor. It is working to display list of available networks and was connected fine right before I ran update. Cable internet is fine right now but wifi still disconnected immediately after I connect.


Hey there David :slight_smile: welcome to the forums.

If you are still being disconnected, run this immediately upon disconnect:
dmesg | tail -25

paste output as a reply so we have an idea what is going wrong for you.

Any other relevant logs regarding errors/networking would help. Use pastebin if they are long :wink:

1 Like

dmesg: read kernel buffer failed: Operation not permitted

1 Like

this was response to dmesg | tail -25 while disconnected and immediately following attempt to connect to wifi

tail: cannot open ‘25’ for reading: No such file or directory
dmesg: read kernel buffer failed: Operation not permitted

1 Like

Anytime something outputs “Operation not permitted” that means you have insufficient privileges to execute the command. You need to use sudo.


Keep searching without being able to connect.
The error I noticed with dmesg is this:
error in setting the pan parameters (5)

1 Like

I got the same problem. It started after some of the recent updates. Cannot connect to any network with my ALFA AWUS036NHA.

dmesg says: “authenticated”, but then “aborting authentication with XX:XX:XX:XX:XX:XX by local choice (Reason: 3=DEAUTH_LEAVING)”. It tries several times and then gives up.

I’m sitting right next to my router, so there can’t be a bad signal.

The same thing in Parrot on a laptop and inside VBox, but all works fine on latest Ubuntu.

I’ve also tried to reinstall the latest Atheros firmware, didn’t help.


Hi there,
I have the same proble with my networt unable to connect to a network , here is dmesg | tail -25 result ;
└──╼ #dmesg | tail -25
[ 20.639829] ieee80211 phy0: Selected rate control algorithm ‘minstrel_ht’
[ 20.640172] usbcore: registered new interface driver rt2800usb
[ 20.848708] rt2800usb 5-5:1.0 wlx000c0b471744: renamed from wlan0
[ 20.885286] gspca_main: gspca_zc3xx-2.14.0 probing 0ac8:303b
[ 21.174656] input: gspca_zc3xx as /devices/pci0000:00/0000:00:1d.1/usb2/2-1/input/input15
[ 21.178380] usbcore: registered new interface driver gspca_zc3xx
[ 27.400616] Initializing XFRM netlink socket
[ 31.580596] RTL8201CP Ethernet r8169-200:00: attached PHY driver [RTL8201CP Ethernet] (mii_bus:phy_addr=r8169-200:00, irq=IGNORE)
[ 31.682611] r8169 0000:02:00.0 eth0: Link is Down
[ 31.690855] ieee80211 phy0: rt2x00lib_request_firmware: Info - Loading firmware file ‘rt2870.bin’
[ 31.973889] rt2800usb 5-5:1.0: firmware: direct-loading firmware rt2870.bin
[ 31.975163] ieee80211 phy0: rt2x00lib_request_firmware: Info - Firmware detected - version: 0.36
[ 313.943728] wlx000c0b471744: authenticate with c4:71:54:07:17:09
[ 313.971761] wlx000c0b471744: send auth to c4:71:54:07:17:09 (try 1/3)
[ 313.973334] wlx000c0b471744: authenticated
[ 320.232218] wlx000c0b471744: authenticate with c4:71:54:07:17:09
[ 320.258359] wlx000c0b471744: send auth to c4:71:54:07:17:09 (try 1/3)
[ 320.261389] wlx000c0b471744: authenticated
[ 326.927767] wlx000c0b471744: authenticate with c4:71:54:07:17:09
[ 326.946615] wlx000c0b471744: send auth to c4:71:54:07:17:09 (try 1/3)
[ 326.949362] wlx000c0b471744: authenticated
[ 331.951823] wlx000c0b471744: aborting authentication with c4:71:54:07:17:09 by local choice (Reason: 3=DEAUTH_LEAVING)
[ 334.188252] wlx000c0b471744: authenticate with c4:71:54:07:17:09
[ 334.211844] wlx000c0b471744: send auth to c4:71:54:07:17:09 (try 1/3)
[ 334.213451] wlx000c0b471744: authenticated

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.