Thunderbird forgets accounts

Briefly describe your issue below:
Everytime I reboot my laptopt and reopen Thunderbird, it asks for my account again, as if this was the first use of Thunderbird.

I tried running parrot-upgrade, which I read from another post (see link below) has solved the problem for another user. This also worked for me at the beginning. However after some other reboots, the problem is back.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
version 4.7 Security edition

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian Standard

Configured to multiboot with other systems? (yes / no)
Yes, with Windows 10

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

anyone have a fix on this yet?

I am seeing the same thing now as well. Just added 6 email accounts yesterday, downloaded email, replied to some…after reboot, Thunderbird “forgot” everything.

Parrot GNU/Linux 4.7
Linux parrot 4.19.37-parrot1-amd64 #1 SMP Parrot 4.19.37-5parrot1 (2019-06-22) x86_64 GNU/Linux

Thunderbird 60.8.0 (64-bit)

I am having the same issue =/ there is nothing I need to upgrade and the only way my profile is loaded is through firejail --noprofile thunderbird. Occasionally my profile will load but only if I restart thunderbird multiple times.

So just in case it slipped through the cracks…Thunderbird is STILL hosed up.

Linux parrot 5.2.0-2parrot1-amd64 #1 SMP Debian 5.2.9-2parrot1 (2019-08-25) x86_64 GNU/Linux
Thunderbird Version: 60.9.0 (64-bit)

The latest normal release version of Thunderbird is now at 68.1 and their latest Beta out of 70.0b3

Any chance our repo will see an upgrade to fix the broken package?

…unless anyone knows a better email client that will run 6-8 email accounts & calendar

As far as I remember the thunderbird docs state, that thunderbird should not be opened with an active Firefox profile. Close Firefox open Thunderbird and it should work, or open Thunderbird before you open Firefox. Well, at least that is the trick that does it for me. It has nothing to do with parrot, firejail or something, it is simply a firefox profile manager thing. With the firejail option you simply bypass the active firefox profile.

When it happens to me, I open a terminal and start thunderbird from there.


If you use multiple thunderbird profiles, or need to a new one. FWIW, I use some mail accounts only via tor so have a separate profile with torbidy.
/usr/bin/thunderbird -profilemanager

So it seems that opening Thunderbird prior to Firefox does the trick…after multiple opens & loses, reboots and parrot-upgrade it still works.

So I would consider that the most reliable work-around

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.