Thunderbird Profile Doesn't load

Briefly describe your issue below:

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Parrot GNU/Linux 4.7 - KDE Home and on Mate

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Configured to multiboot with other systems? (yes / no)
yes computer w w7 and 1 with ubuntu 19.04
If there are any similar issues or solutions, link to them below:
Firejail issue I think
If there are any error messages or relevant logs, post them below:

have to run with firejail --noprofile
The directory ‘/home/karma/.gnupg’ containing your OpenPGP keys is not writable. Please fix the directory permissions or change the location of your GnuPG “home” directory. GnuPG cannot work correctly otherwise.

.gnupg folder user:nobody, group:nobody

firejail --noprofile thunderbird
Warning: an existing sandbox was detected. thunderbird will run without any additional sandboxing features
Warning: an existing sandbox was detected. /usr/bin/thunderbird will run without any additional sandboxing features
Gtk-Message: 10:05:34.696: Failed to load module “appmenu-gtk-module”

Basically if I open Thunderbird the normal way, it doesn’t use the profiles.ini file in .thunderbird home folder. It opens asking to create new accounts.

If I run with firejail --noprofile, it opens and runs with my profile and account settings, but then enigmail can’t reach .gnupg.

This problems occurs in both my laptop and desktop, one with KDE other with Mate.

I did have recent update, and I also did recently switch from firefox-esr, to the newer one in the parrot repo.


OK, so a re-boot fixed this problem, on both machines.

I did reboot after parrot-upgrade, so I don’t know what caused the problem, but I think the issue can be closed.

If it happens again, I’ll udpate.


This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.

Hi. Sorry for lately reply (i am in gmt +7). It is possibly old thunderbird profile has bad logic configurations and upgrade fixed it (reboot helped system use new profiles).