[TOMOYO] Problem starting the computer

Today when I started my computer I got the following message:
TOMOYO: select from the following list:

The list was empty, I only saw “disable” there.

After writing disable the computer booted.
How I can fix that?
Yesterday the computer had the full upgrade.
4.14.0-parrot13-amd64 #1 SMP Parrot 4.14.13-1parrot13 (2018-01-21) x86_64 GNU/Linux
My disk is encrypted and after each upgrade I need to run
get-apt autoremove --purge
because the boot disk keep without space.

1 Like

type “disable” > push Enter > apt dist-upgrade

2 Likes

After I write “disable” and push Enter
the computer boots immediately and I don’ t have time to write ‘apt dist-upgrade’
When the computer finishes booting I run apt dist-upgrade but it didn’ t solve the problem.
When the computer boot I get always:

TOMOYO: Default profile doesn’ t exist
TOMOYO: select from the following list:
Disable

Any other sugestion to fix the problem?
Thanks in advance for your help

was the dist-upgrade successfull ?

I got that:

sudo apt dist-upgrade

Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following packages have been kept back:
pocl-opencl-icd python-qscintilla2
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

do you apt update before it ?

No but now I did
apt update
apt dist-upgrade
apt upgrade

I reboot and I had the same problem with the same messages.

okay typ this > sudo apt install parrot-core>sudo apt autoremove>sudo apt autoclean

sudo apt update && sudo apt dist-upgrade

The solution to this problem is quite simple. When you run the “apt-get autoremove” command it will display the list of packages that will be uninstalled and asks for your permission to continue, at this point much attention, type “n” to abort the process.

Now just copy the list that was displayed and have them all reinstall. Apt-get will then mark the packages as “manual installation” and therefore will unlink the dependencies with the first package that was previously removed.

If you prefer to do this in graphical mode, open Synaptic, select the “auto-removable” packages, click “Package” in the menu and uncheck the “Automatically installed” option.

Hey guys i got the same problem :persevere: i you fini the solution i want to know i got this on 2 pc on parrot :relieved:

when boot parrot you will see error typ( disable ) than you will see parrot open open treminal and typ (sudo apt install parrot-core )than sudo autoremove and upgrade your parrot

3 Likes

Thank you very much ! :slight_smile:

1 Like

My system says that I have 1 package that can be upgraded: “tomoyo-tools”. But in order to do so, I must first uninstall “parrot-core”. So what should I do? None above sugestions helped…When I run:
“sudo apt update && sudo apt dist-upgrade” I got this:
"1 package can be upgraded. Run ‘apt list --upgradable’ to see it.
Reading package lists… Done
**Building dependency tree **
Reading state information… Done
Calculating upgrade… Done
The following packages have been kept back:
** tomoyo-tools**
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded."
What should I do? Leave like it is?
(In some other post, Palinuro mention that rolling distros should not run command with
"dist-upgrade" but instead “full-upgrade” in order to update OS…like this:
“sudo apt update && sudo apt full-upgrade” -I know this cant solve this problem, just mentioning)

Just leave it downgraded, there is a reason why it was kept back.

Thread closed, solution marked.

1 Like

You need to add in /etc/default/grub this: GRUB_CMDLINE_LINUX_DEFAULT=“quiet security=tomoyo”, then do update-grub, reboot, and have fun.