Tor browser 9.0 black window

After updating tor browser to 9.0, the entire browser window is black, nothing can be done. Deleting a user profile did not help

Parrot OS 4.7 Home x64, Vbox 6.0.14


dude same problem in here too I tried purge remove and reinstalled torbrowser-… but nothings work :frowning:

Exactly same problem also for most likely 3 hours ago, i have not updated or anything

edit it might updated without me noticing it it

oh it makes sense now, dev’s might acknowledged this issue that’s why not responding to this problem! :slight_smile: smart ones and how come you got the issue without even updating? May be auto update enabled? :worried:

I always use update and upgrade; but first time i updated in the browser itself in parrot home, and made me to download tor tar and use it. Sad

it is a problem with apparmor profile ( for now to make torbrowser work you should disable TB apparmor profile:
sudo ln -s /etc/apparmor.d/torbrowser.Browser.firefox /etc/apparmor.d/disable/
sudo apparmor_parser -R /etc/apparmor.d/torbrowser.Browser.firefox

it’s obvously not a final solution!

oops @n0u4n do you think disabling apparmor is a good option? or better to download tor tar and use?

have you got any idea to fix this issue?

sorry man, I’m not so skilled in apparmor but i’m asking if using TB from tar it’s not the same as using it without an apparmor profile. however i think one should put TB apparmor profile in complain mode and try to guess the problem. I’m taking a look. Adding owner /{dev,run}/shm/org.mozilla.ipc.*.* rw, in the profile file let TB apparently work in enforced mode. if anyone knows better how aa works please help us. bye

sorry i don’t use graphical file manager…

after fixing (as said above) the apparmor problem, after today’s upgrade torbrowser doesn’t start at all. it’s a apparmor problem again. I put tb profile in complain mode waiting for a fix. is there any news?

for me, replacing the current apparmor profile with this one fix the problem

these were the differences

$ diff torbrowser.Browser.firefox torbrowser.Browser.firefox.dpkg-old -d                                                                      
<   owner @{torbrowser_home_dir}/updater ix,
<   owner @{torbrowser_firefox_executable} pxmr -> torbrowser_firefox,
>   owner @{torbrowser_firefox_executable} ixmr -> torbrowser_firefox,
<   owner /dev/shm/org.mozilla.ipc.[0-9]*.[0-9]* rw, # for Chromium IPC
<   # u2f (tested with Yubikey 4)
<   /sys/class/ r,
<   /sys/bus/ r,
<   /sys/class/hidraw/ r,
<   /run/udev/data/c24{7,9}:* r,
<   /dev/hidraw* rw,
<   # Yubikey NEO also needs this:
<   /sys/devices/**/hidraw/hidraw*/uevent r,

This has been tested and approved as a fix.

A apparmor profile problem with Torbrowser 9.0
Open a Terminal and type the following.

sudo nano /etc/apparmor.d/local/torbrowser.Browser.firefox

Then add the line:
owner /{dev,run}/shm/org.mozilla.*.* rw,

save your file. And then in the terminal restart apparmor by typing:

systemctl restart apparmor

You may also view the Debian bug report and solution here at:


Thanks mine have worked i had the same problem

how to save the file ???
please help iam new to parrot os .

Hey @swapnil , when you open a text with nano , at the bottom of your window you have this :

So to save , you need to exit first ( ctrl + x ) , Nano going to offer to save your changes. say yes ( y ) , but does not change the name of the file .
Nano will close, you will be able to check that your exchanges have been taken into account by reopening the famous text file again.
Hope that can help you .


This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.