Tor browser not working

when i start tor browser it only shows black window and doesn’t do anything except using ram.i tried to reinstall it but it still doesn’t work.i searched many things but nothing works here,for my problem.

i’m using parrot 4.7

i installed parrot os from flash driver
Configured to multiboot with other systems? (yes / no)
i searched but didn’t found anything about this issue

there aren’t any error messages

1 Like

Welcome to the forum :slight_smile:

Tor ‘black screen’ has been addressed. Looking back at one of the marked solutions, there is an additional word at beginning of the line that may have caused confusion for you “edit :” (removing that word to fix now).

1.) Close blackscreen tor browser.

2.) Edit /etc/apparmor.d/local/torbrowser.Browser.firefox

3.) Add this one line to that file, exactly as shown below (make sure to delete anything else in file):
owner /{dev,run}/shm/org.mozilla.*.* rw,

4.) Now issue:
sudo systemctl restart apparmor

Retart Tor browser again from menu and reply here to let me know it works for you :slight_smile:


tor browser is working perfect on Parrot-security-4.8-exp6_x64.iso

tor browser launcher settings from applications/internet menu

click install tor browser then once it completes tor browser loads perfect


1 Like

The issue has been patched for quite some time now on 4.7
4.8 is still in beta. Wont suggest messing around with it unless user knows what they’re upto.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.