Tor Browser Version 10 has Broken torbrowser-launcher

Hello

I recently allowed my tor browser to update on both of my Parrot OS machines to version 10. Since then, the torbrowser-launcher fails to load tor browser from the shortcut on both machines.

If I try to reinstall Tor Browser through torbrowser-launcher it fails throwing me the error that the version I received is too early.

I suspect that the torbrowser-launcher included in the distro requires an update to support version 10?

Has anyone else experienced this issue and if not ,how could I go about fixing it?

  1. did you try search in community? there was a topic with fix
  2. Do you have any error log?

Hello Dmknight,

There seems to be a rush on over at github to fix this. Are you not having this issue? My tor-browser launcher just throws and error that the version is incorrect. The app armour profile is also broken. This is being reflected on the issues page on the github.
Is tor-browser launcher part of the parrot-privacy package? Have the devs had any problems with this?

This error is thrown from the launcher, the launcher then hangs.

The launcher then fails to start and is unresponsive to clicks. You can launch tor browser through the local file in /home/.local/share/torbrowser/tbb/x86_64/tor-browser_en-US

Yes i don’t have this issue at all. Maybe you can show your launcher version sudo apt show torbrowser-launcher
Mine Version: 0.3.2-13 and im using rolling-testing branch
P/s: calling launcher from menu worked fine. I’ve tried cli and yes i got the problem and now i can’t open the browser

First bug problem: i am debugging, and as the issue on github mentioned, the problem is "10.0" <= "7.5.0" == true in Python. It is simple string comparison problem. I have an idea how to fix it by using a for loop but it is not the best idea


My patch for this error. The code is at launcher.py. /usr/lib/python3/dist-packages/torbrowser_launcher/launcher.py

1 Like

Hello dmknght,

Thanks for offering your potential solution. I will give some stuff ago.

I see you have put your solution on the github, hopefully a fix is pushed through the official repository. I will keep my eye out.


Someone has built a flatpack version with a fix.

Oh i didn’t notice that. Yes the fix is the same but the code is more beautiful. The mindset is split version to a tuple (mine is a list) and convert value to int to compare.

1 Like

Well,
fixed launcher in the repo when?
Thanks

@SecParrot

Hello dmknght,

I have installed the flatpak version maintained by ASCIIWolf. Works great.
https://flathub.org/apps/details/com.github.micahflee.torbrowser-launcher

Do you have any idea when a fix will be pushed officially in parrot?

It seems the original dev has abandoned the project, may be wise to create a new branch for Parrot or bundle the flatpak version?

Yes i have

No it isn’t

No

Parrot team is sending an email about the fix to the Debian team. Hopefully they will fix it asap and we both have fixed release.