Trouble in installing apps

Briefly describe your issue below:
I was trying to get a couple apps (Cowsay, Telegram) working on my Parrot running HP Omen.
Well, I tried a couple methods: ‘git clone …’ , downloading the tar file, ‘sudo apt-get’ .
I haven’t had success, though. So, I wanted to know whether it was possible to install third-party apps for Parrot as it is based on security/privacy.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
4.6 Home/KDE

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian Standard

Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Telegram is in our repo, so you can install it using sudo apt install telegram-desktop

Cowsay should already be installed.

When searching for packages to install you can use apt-cache e.g. apt-cache search telegram. It will then list all packages related to the string provided.

1 Like

Does Spotify cause trouble on installing ?
I used the Debian method mentioned on the Spotify’s official website.

# 1. Add the Spotify repository signing keys to be able to verify downloaded packages
sudo apt-key adv --keyserver hkp:// --recv-keys 931FF8E79F0876134EDDBDCCA87FF9DF48BF1C90

# 2. Add the Spotify repository
echo deb stable non-free | sudo tee /etc/apt/sources.list.d/spotify.list

# 3. Update list of available packages
sudo apt-get update

# 4. Install Spotify
sudo apt-get install spotify-client

I have been having issues with sound like sometimes system stops playing any sort of sounds and then I have to restart it to get the soundcard working again. System settings vanish in such cases. After restart, it seems to be fine again but I am worried if I have done anything wrong.

Don’t add External repo
Maybe spofy available into snap store (better then adding repo)

I am also experiencing a similar problem but a different problem too, I am using
Linux parrot 4.19.0-parrot4-28t-amd64 #1 SMP Parrot 4.19.28-2parrot4.28t (2019-04-18) x86_64 GNU/Linux
so I tried to install vm and got the following error
Failed to fetch Temporary failure resolving ‘
am currently connected to a proxy network which I did configure my browser to use the proxy and the browser is working fine but the error message still exist
I suspect that its my machine (not the virtual machine but rather the device am using) which is not fully connected to he proxy network. please help and help and help and help, I also cant update machine because of the same problem

  1. Change mirror ,
  2. Stop anonsurf
  • start anonsurf
    Restart network-manager

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.